1 ################################################################################
5 ################################################################################
8 IODINE_SITE
= http
://code.kryo.se
/iodine
9 IODINE_DEPENDENCIES
= zlib
11 IODINE_LICENSE_FILES
= README
13 IODINE_CFLAGS
= $(TARGET_CFLAGS
)
15 # iodine contains a local implementation of daemon(3) for older
16 # systems, unless __GLIBC__ is defined. Musl does provide it, but
17 # unlike uClibc it doesn't define __GLIBC__. Work around it by
18 # pretending to be glibc as we otherwise end up with symbol conflicts.
19 ifeq ($(BR2_TOOLCHAIN_USES_MUSL
),y
)
20 IODINE_CFLAGS
+= -D__GLIBC__
23 define IODINE_BUILD_CMDS
24 $(TARGET_CONFIGURE_OPTS
) CFLAGS
="$(IODINE_CFLAGS)" \
25 $(MAKE
) ARCH
=$(BR2_ARCH
) -C
$(@D
)
28 define IODINE_INSTALL_TARGET_CMDS
29 $(TARGET_CONFIGURE_OPTS
) $(MAKE
) -C
$(@D
) install DESTDIR
="$(TARGET_DIR)" prefix=/usr
32 $(eval
$(generic-package
))