mesa3d-headers: remove installation of OpenVG headers
[buildroot-gz.git] / package / webp / webp.mk
blobd579d56c5e632f88c9c6d753223e82151b648d80
1 ################################################################################
3 # webp
5 ################################################################################
7 WEBP_VERSION = 0.5.2
8 WEBP_SOURCE = libwebp-$(WEBP_VERSION).tar.gz
9 WEBP_SITE = http://downloads.webmproject.org/releases/webp
10 WEBP_LICENSE = BSD-3c
11 WEBP_LICENSE_FILES = COPYING
12 WEBP_INSTALL_STAGING = YES
14 WEBP_CONF_OPTS += \
15 --with-jpegincludedir=$(STAGING_DIR)/usr/include \
16 --with-jpeglibdir=$(STAGING_DIR)/usr/lib \
17 --with-tiffincludedir=$(STAGING_DIR)/usr/include \
18 --with-tifflibdir=$(STAGING_DIR)/usr/lib
20 ifeq ($(BR2_PACKAGE_WEBP_DEMUX),y)
21 WEBP_CONF_OPTS += --enable-libwebpdemux
22 else
23 WEBP_CONF_OPTS += --disable-libwebpdemux
24 endif
26 ifeq ($(BR2_PACKAGE_LIBPNG),y)
27 WEBP_DEPENDENCIES += libpng
28 WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
29 else
30 WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=/bin/false
31 endif
33 WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
34 WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_TIFF),tiff)
36 $(eval $(autotools-package))