uclibc: fix two more regressions introduced in 1.0.18
[buildroot-gz.git] / package / libtool / libtool.mk
blob1d066bd1ec06bd9677a09bcfe4a62000c9fba5b7
1 ################################################################################
3 # libtool
5 ################################################################################
7 LIBTOOL_VERSION = 2.4.6
8 LIBTOOL_SOURCE = libtool-$(LIBTOOL_VERSION).tar.xz
9 LIBTOOL_SITE = $(BR2_GNU_MIRROR)/libtool
10 LIBTOOL_INSTALL_STAGING = YES
11 LIBTOOL_CONF_ENV = HELP2MAN=true
12 LIBTOOL_DEPENDENCIES = host-m4
13 HOST_LIBTOOL_DEPENDENCIES = host-m4
14 LIBTOOL_LICENSE = GPLv2+
15 LIBTOOL_LICENSE_FILES = COPYING
17 HOST_LIBTOOL_CONF_ENV = MAKEINFO=true
18 HOST_LIBTOOL_LIBTOOL_PATCH = NO
20 # We have a patch that affects libtool.m4, which triggers an autoreconf
21 # in the build step. Normally we would set AUTORECONF = YES, but this
22 # doesn't work for host-libtool because that creates a circular
23 # dependency. Instead, touch the generated files so autoreconf is not
24 # triggered in the build step. Note that aclocal.m4 has to be touched
25 # first since the rest depends on it. Note that we don't need the changes
26 # in libtool.m4 in our configure script, because we're not actually
27 # running it on the target.
28 # For the target, we would normally be able to use AUTORECONF, but it
29 # fails on libltdl/Makefile.inc. Rather than trying to fix that failure,
30 # just use the same hack as on the host.
31 define LIBTOOL_AVOID_AUTORECONF_HOOK
32 find $(@D) -name aclocal.m4 -exec touch '{}' \;
33 find $(@D) -name config-h.in -exec touch '{}' \;
34 find $(@D) -name configure -exec touch '{}' \;
35 find $(@D) -name Makefile.in -exec touch '{}' \;
36 endef
37 LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
38 HOST_LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
40 $(eval $(autotools-package))
41 $(eval $(host-autotools-package))
43 # variables used by other packages
44 LIBTOOL = $(HOST_DIR)/usr/bin/libtool
45 LIBTOOLIZE = $(HOST_DIR)/usr/bin/libtoolize