1 ################################################################################
5 ################################################################################
8 ATTR_SOURCE
= attr-
$(ATTR_VERSION
).src.
tar.gz
9 ATTR_SITE
= http
://download.savannah.gnu.org
/releases
/attr
10 ATTR_INSTALL_STAGING
= YES
11 ATTR_CONF_OPTS
= --enable-gettext
=no
12 HOST_ATTR_CONF_OPTS
= --enable-gettext
=no
13 ATTR_LICENSE
= GPLv2
+ (programs
), LGPLv2.1
+ (libraries
)
14 ATTR_LICENSE_FILES
= doc
/COPYING doc
/COPYING.LGPL
16 # While the configuration system uses autoconf, the Makefiles are
17 # hand-written and do not use automake. Therefore, we have to hack
18 # around their deficiencies by passing installation paths.
19 ATTR_INSTALL_STAGING_OPTS
= \
20 prefix=$(STAGING_DIR
)/usr \
21 exec_prefix=$(STAGING_DIR
)/usr \
22 PKG_DEVLIB_DIR
=$(STAGING_DIR
)/usr
/lib \
23 install-dev install-lib
25 ATTR_INSTALL_TARGET_OPTS
= \
26 prefix=$(TARGET_DIR
)/usr \
27 exec_prefix=$(TARGET_DIR
)/usr \
30 HOST_ATTR_INSTALL_OPTS
= \
31 prefix=$(HOST_DIR
)/usr \
32 exec_prefix=$(HOST_DIR
)/usr \
33 install-dev install-lib
35 # The libdir variable in libattr.la is empty, so let's fix it. This is
36 # probably due to attr not using automake, and not doing fully the
37 # right thing with libtool.
38 define ATTR_FIX_LIBTOOL_LA_LIBDIR
39 $(SED
) "s,libdir=.*,libdir='$(STAGING_DIR)'," \
40 $(STAGING_DIR
)/usr
/lib
/libattr.la
43 ATTR_POST_INSTALL_STAGING_HOOKS
+= ATTR_FIX_LIBTOOL_LA_LIBDIR
45 $(eval
$(autotools-package
))
46 $(eval
$(host-autotools-package
))