fontconfig: needs host-gperf
[buildroot-gz.git] / package / libedit / libedit.mk
blobe7ddd1fcb56238fbcb498328cb8ec52dd4fd9a28
1 ################################################################################
3 # libedit
5 ################################################################################
7 LIBEDIT_VERSION = 20150325-3.1
8 LIBEDIT_SITE = http://www.thrysoee.dk/editline
9 LIBEDIT_INSTALL_STAGING = YES
10 LIBEDIT_DEPENDENCIES = ncurses
11 LIBEDIT_LICENSE = BSD-3c
12 LIBEDIT_LICENSE_FILES = COPYING
14 # We're patching configure.ac
15 LIBEDIT_AUTORECONF = YES
17 # Needed for autoreconf to work properly
18 define LIBEDIT_FIXUP_M4_DIR
19 mkdir $(@D)/m4
20 endef
21 LIBEDIT_POST_EXTRACT_HOOKS += LIBEDIT_FIXUP_M4_DIR
23 # Doesn't really support !wchar, but support is disabled otherwise
24 LIBEDIT_CONF_OPTS += --enable-widec
26 # musl is ISO 10646 compliant but doesn't define __STDC_ISO_10646__,
27 # so let's define it manually
28 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
29 LIBEDIT_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -D__STDC_ISO_10646__=201103L"
30 endif
32 # Note: libbsd required for *vis functions, but works only with a toolchain
33 # with __progname; otherwise, some features are disabled, as if libbsd was
34 # missing entirely.
35 ifeq ($(BR2_PACKAGE_LIBBSD),y)
36 LIBEDIT_DEPENDENCIES += libbsd
37 endif
39 $(eval $(autotools-package))