fontconfig: needs host-gperf
[buildroot-gz.git] / package / lvm2 / lvm2.mk
bloba2d484bc250a38ad22e06386b2d3cda84291d8ba
1 ################################################################################
3 # lvm2
5 ################################################################################
7 LVM2_VERSION = 2.02.168
8 LVM2_SOURCE = LVM2.$(LVM2_VERSION).tgz
9 LVM2_SITE = ftp://sources.redhat.com/pub/lvm2/releases
10 LVM2_INSTALL_STAGING = YES
11 LVM2_LICENSE = GPLv2, LGPLv2.1
12 LVM2_LICENSE_FILES = COPYING COPYING.LIB
14 # Make sure that binaries and libraries are installed with write
15 # permissions for the owner.
16 LVM2_CONF_OPTS += \
17 --enable-write_install \
18 --enable-pkgconfig \
19 --enable-cmdlib \
20 --enable-dmeventd
22 # LVM2 uses autoconf, but not automake, and the build system does not
23 # take into account the toolchain passed at configure time.
24 LVM2_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
26 ifeq ($(BR2_PACKAGE_READLINE),y)
27 LVM2_DEPENDENCIES += readline
28 else
29 # v2.02.44: disable readline usage, or binaries are linked against provider
30 # of "tgetent" (=> ncurses) even if it's not used..
31 LVM2_CONF_OPTS += --disable-readline
32 endif
34 ifeq ($(BR2_PACKAGE_LVM2_STANDARD_INSTALL),)
35 LVM2_MAKE_OPTS = device-mapper
36 LVM2_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install_device-mapper
37 LVM2_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install_device-mapper
38 endif
40 ifeq ($(BR2_PACKAGE_LVM2_APP_LIBRARY),y)
41 LVM2_CONF_OPTS += --enable-applib
42 else
43 LVM2_CONF_OPTS += --disable-applib
44 endif
46 ifeq ($(BR2_TOOLCHAIN_SUPPORTS_PIE),)
47 LVM2_CONF_ENV += ac_cv_flag_HAVE_PIE=no
48 endif
50 $(eval $(autotools-package))