syslinux: install helper programs to the host
[buildroot-gz.git] / package / weston / weston.mk
blobb6b8556f893c07c35eca110ead28a2c7195900dc
1 ################################################################################
3 # weston
5 ################################################################################
7 WESTON_VERSION = 1.4.0
8 WESTON_SITE = http://wayland.freedesktop.org/releases/
9 WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
10 WESTON_LICENSE = MIT
11 WESTON_LICENSE_FILES = COPYING
13 WESTON_DEPENDENCIES = host-pkgconf wayland libxkbcommon pixman libpng \
14 jpeg mtdev udev cairo
16 # We're touching Makefile.am
17 WESTON_AUTORECONF = YES
19 WESTON_CONF_OPT = \
20 --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
21 --disable-egl \
22 --disable-simple-egl-clients \
23 --disable-xwayland \
24 --disable-x11-compositor \
25 --disable-drm-compositor \
26 --disable-wayland-compositor \
27 --disable-headless-compositor \
28 --disable-weston-launch \
29 --disable-colord
31 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
32 WESTON_DEPENDENCIES += libunwind
33 else
34 WESTON_CONF_OPT += --disable-libunwind
35 endif
37 ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
38 WESTON_CONF_OPT += --enable-fbdev-compositor
39 else
40 WESTON_CONF_OPT += --disable-fbdev-compositor
41 endif
43 ifeq ($(BR2_PACKAGE_WESTON_RPI),y)
44 WESTON_DEPENDENCIES += rpi-userland
45 WESTON_CONF_OPT += --enable-rpi-compositor \
46 --disable-resize-optimization \
47 --disable-setuid-install \
48 --disable-xwayland-test \
49 --disable-simple-egl-clients \
50 WESTON_NATIVE_BACKEND=rpi-backend.so
51 else
52 WESTON_CONF_OPT += --disable-rpi-compositor
53 endif # BR2_PACKAGE_WESTON_RPI
55 $(eval $(autotools-package))