1 ################################################################################
5 ################################################################################
8 WESTON_SITE
= http
://wayland.freedesktop.org
/releases
/
9 WESTON_SOURCE
= weston-
$(WESTON_VERSION
).
tar.xz
11 WESTON_LICENSE_FILES
= COPYING
13 WESTON_DEPENDENCIES
= host-pkgconf wayland libxkbcommon pixman libpng \
16 # We're touching Makefile.am
17 WESTON_AUTORECONF
= YES
20 --with-dtddir
=$(STAGING_DIR
)/usr
/share
/wayland \
22 --disable-simple-egl-clients \
24 --disable-x11-compositor \
25 --disable-drm-compositor \
26 --disable-wayland-compositor \
27 --disable-headless-compositor \
28 --disable-weston-launch \
31 ifeq ($(BR2_PACKAGE_LIBUNWIND
),y
)
32 WESTON_DEPENDENCIES
+= libunwind
34 WESTON_CONF_OPT
+= --disable-libunwind
37 ifeq ($(BR2_PACKAGE_WESTON_FBDEV
),y
)
38 WESTON_CONF_OPT
+= --enable-fbdev-compositor
40 WESTON_CONF_OPT
+= --disable-fbdev-compositor
43 ifeq ($(BR2_PACKAGE_WESTON_RPI
),y
)
44 WESTON_DEPENDENCIES
+= rpi-userland
45 WESTON_CONF_OPT
+= --enable-rpi-compositor \
46 --disable-resize-optimization \
47 --disable-setuid-install \
48 --disable-xwayland-test \
49 --disable-simple-egl-clients \
50 WESTON_NATIVE_BACKEND
=rpi-backend.so
52 WESTON_CONF_OPT
+= --disable-rpi-compositor
53 endif # BR2_PACKAGE_WESTON_RPI
55 $(eval
$(autotools-package
))