1 ################################################################################
5 ################################################################################
7 LIBEVENT_VERSION
= 2.0.22-stable
8 LIBEVENT_SITE
= https
://github.com
/libevent
/libevent
/releases
/download
/release-
$(LIBEVENT_VERSION
)
9 LIBEVENT_INSTALL_STAGING
= YES
10 LIBEVENT_LICENSE
= BSD-3c
, OpenBSD
11 LIBEVENT_LICENSE_FILES
= LICENSE
12 # For 0001-Disable-building-test-programs.patch
13 LIBEVENT_AUTORECONF
= YES
15 define LIBEVENT_REMOVE_PYSCRIPT
16 rm $(TARGET_DIR
)/usr
/bin
/event_rpcgen.py
19 # libevent installs a python script to target - get rid of it if we
20 # don't have python support enabled
21 ifneq ($(BR2_PACKAGE_PYTHON
),y
)
22 LIBEVENT_POST_INSTALL_TARGET_HOOKS
+= LIBEVENT_REMOVE_PYSCRIPT
25 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
26 LIBEVENT_DEPENDENCIES
+= openssl
27 LIBEVENT_CONF_OPTS
+= --enable-openssl
28 # openssl needs zlib but configure forgets to link against it causing
29 # openssl detection to fail
30 ifeq ($(BR2_STATIC_LIBS
),y
)
31 LIBEVENT_CONF_ENV
+= OPENSSL_LIBADD
='-lz'
34 LIBEVENT_CONF_OPTS
+= --disable-openssl
37 $(eval
$(autotools-package
))
38 $(eval
$(host-autotools-package
))