python-whoosh: bump to version 2.7.4
[buildroot-gz.git] / package / libevent / libevent.mk
blob5458ce316a9c4d036cdfa76c5efb94fed8390899
1 ################################################################################
3 # libevent
5 ################################################################################
7 LIBEVENT_VERSION = 2.1.8-stable
8 LIBEVENT_SITE = https://github.com/libevent/libevent/releases/download/release-$(LIBEVENT_VERSION)
9 LIBEVENT_INSTALL_STAGING = YES
10 LIBEVENT_LICENSE = BSD-3c, OpenBSD
11 LIBEVENT_LICENSE_FILES = LICENSE
12 # For 0001-Disable-building-test-programs.patch
13 LIBEVENT_AUTORECONF = YES
14 LIBEVENT_CONF_OPTS = --disable-samples
16 define LIBEVENT_REMOVE_PYSCRIPT
17 rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
18 endef
20 # libevent installs a python script to target - get rid of it if we
21 # don't have python support enabled
22 ifneq ($(BR2_PACKAGE_PYTHON),y)
23 LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
24 endif
26 ifeq ($(BR2_PACKAGE_OPENSSL),y)
27 LIBEVENT_DEPENDENCIES += host-pkgconf openssl
28 LIBEVENT_CONF_OPTS += --enable-openssl
29 else
30 LIBEVENT_CONF_OPTS += --disable-openssl
31 endif
33 $(eval $(autotools-package))
34 $(eval $(host-autotools-package))