1 ################################################################################
5 ################################################################################
7 CA_CERTIFICATES_VERSION
= 20161130
8 CA_CERTIFICATES_SOURCE
= ca-certificates_
$(CA_CERTIFICATES_VERSION
).
tar.xz
9 CA_CERTIFICATES_SITE
= http
://snapshot.debian.org
/archive
/debian
/20161205T153846Z
/pool
/main
/c
/ca-certificates
10 CA_CERTIFICATES_DEPENDENCIES
= host-openssl
11 # ca-certificates can be built with either python 2 or python 3
12 # but it must be at least python 2.7
13 CA_CERTIFICATES_DEPENDENCIES
+= \
14 $(if
$(BR2_PACKAGE_PYTHON3
),host-python3
,host-python
)
15 CA_CERTIFICATES_LICENSE
= GPLv2
+ (script
), MPLv2.0
(data
)
16 CA_CERTIFICATES_LICENSE_FILES
= debian
/copyright
18 define CA_CERTIFICATES_BUILD_CMDS
19 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) all
22 define CA_CERTIFICATES_INSTALL_TARGET_CMDS
23 $(INSTALL
) -d
-m
0755 $(TARGET_DIR
)/usr
/share
/ca-certificates
24 $(INSTALL
) -d
-m
0755 $(TARGET_DIR
)/etc
/ssl
/certs
25 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) install DESTDIR
=$(TARGET_DIR
)
26 rm -f
$(TARGET_DIR
)/usr
/sbin
/update-ca-certificates
28 # Remove any existing certificates under /etc/ssl/certs
29 rm -f
$(TARGET_DIR
)/etc
/ssl
/certs
/*
31 # Create symlinks to certificates under /etc/ssl/certs
32 # and generate the bundle
34 for i in
`find usr/share/ca-certificates -name "*.crt"` ; do \
35 ln
-sf ..
/..
/..
/$$i etc
/ssl
/certs
/`basename $${i} .crt`.pem
;\
36 cat
$$i >>etc
/ssl
/certs
/ca-certificates.crt
;\
39 # Create symlinks to the certificates by their hash values
40 $(HOST_DIR
)/usr
/bin
/c_rehash
$(TARGET_DIR
)/etc
/ssl
/certs
43 $(eval
$(generic-package
))