python-pyasn: bump to version 1.6.0b1
[buildroot-gz.git] / package / flac / flac.mk
blob43e0410df53e366533ef2062f8ae03107413d943
1 ################################################################################
3 # flac
5 ################################################################################
7 FLAC_VERSION = 1.3.2
8 FLAC_SITE = http://downloads.xiph.org/releases/flac
9 FLAC_SOURCE = flac-$(FLAC_VERSION).tar.xz
10 FLAC_INSTALL_STAGING = YES
11 FLAC_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
12 FLAC_LICENSE = Xiph BSD-like (libFLAC), GPLv2+ (tools), LGPLv2.1+ (other libraries)
13 FLAC_LICENSE_FILES = COPYING.Xiph COPYING.GPL COPYING.LGPL
14 # 0001-configure.ac-relax-linux-OS-detection.patch patches configure.ac
15 FLAC_AUTORECONF = YES
16 FLAC_CONF_OPTS = \
17 --disable-cpplibs \
18 --disable-xmms-plugin \
19 --disable-altivec
21 ifeq ($(BR2_PACKAGE_LIBOGG),y)
22 FLAC_CONF_OPTS += --with-ogg=$(STAGING_DIR)/usr
23 FLAC_DEPENDENCIES += libogg
24 else
25 FLAC_CONF_OPTS += --disable-ogg
26 endif
28 ifeq ($(BR2_X86_CPU_HAS_SSE),y)
29 FLAC_DEPENDENCIES += host-nasm
30 FLAC_CONF_OPTS += --enable-sse
31 else
32 FLAC_CONF_OPTS += --disable-sse
33 endif
35 $(eval $(autotools-package))