python-pyasn: bump to version 1.6.0b1
[buildroot-gz.git] / package / git / git.mk
blob1c157400762ff62258e25bc03e828d56cbf48265
1 ################################################################################
3 # git
5 ################################################################################
7 GIT_VERSION = 2.11.1
8 GIT_SOURCE = git-$(GIT_VERSION).tar.xz
9 GIT_SITE = https://www.kernel.org/pub/software/scm/git
10 GIT_LICENSE = GPLv2, LGPLv2.1+
11 GIT_LICENSE_FILES = COPYING LGPL-2.1
12 GIT_DEPENDENCIES = zlib host-gettext
14 ifeq ($(BR2_PACKAGE_OPENSSL),y)
15 GIT_DEPENDENCIES += openssl
16 GIT_CONF_OPTS += --with-openssl
17 GIT_CONF_ENV_LIBS += $(if $(BR2_STATIC_LIBS),-lz)
18 else
19 GIT_CONF_OPTS += --without-openssl
20 endif
22 ifeq ($(BR2_PACKAGE_PERL),y)
23 GIT_DEPENDENCIES += perl
24 GIT_CONF_OPTS += --with-libpcre
25 else
26 GIT_CONF_OPTS += --without-libpcre
27 endif
29 ifeq ($(BR2_PACKAGE_LIBCURL),y)
30 GIT_DEPENDENCIES += libcurl
31 GIT_CONF_OPTS += --with-curl
32 GIT_CONF_ENV += \
33 ac_cv_prog_curl_config=$(STAGING_DIR)/usr/bin/$(LIBCURL_CONFIG_SCRIPTS)
34 else
35 GIT_CONF_OPTS += --without-curl
36 endif
38 ifeq ($(BR2_PACKAGE_EXPAT),y)
39 GIT_DEPENDENCIES += expat
40 GIT_CONF_OPTS += --with-expat
41 else
42 GIT_CONF_OPTS += --without-expat
43 endif
45 ifeq ($(BR2_PACKAGE_LIBICONV),y)
46 GIT_DEPENDENCIES += libiconv
47 GIT_CONF_ENV_LIBS += -liconv
48 GIT_CONF_OPTS += --with-iconv=/usr/lib
49 else
50 GIT_CONF_OPTS += --without-iconv
51 endif
53 ifeq ($(BR2_PACKAGE_TCL),y)
54 GIT_DEPENDENCIES += tcl
55 GIT_CONF_OPTS += --with-tcltk
56 else
57 GIT_CONF_OPTS += --without-tcltk
58 endif
60 # assume yes for these tests, configure will bail out otherwise
61 # saying error: cannot run test program while cross compiling
62 GIT_CONF_ENV += \
63 ac_cv_fread_reads_directories=yes \
64 ac_cv_snprintf_returns_bogus=yes LIBS='$(GIT_CONF_ENV_LIBS)'
66 $(eval $(autotools-package))