1 ################################################################################
5 ################################################################################
8 JAMVM_SITE
= http
://downloads.sourceforge.net
/project
/jamvm
/jamvm
/JamVM
%20$(JAMVM_VERSION
)
10 JAMVM_LICENSE_FILES
= COPYING
11 JAMVM_DEPENDENCIES
= zlib classpath
12 # For 0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch
13 JAMVM_AUTORECONF
= YES
14 # int inlining seems to crash jamvm, don't build shared version of internal lib
16 --with-classpath-install-dir
=/usr \
17 --disable-int-inlining \
21 # jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
22 # so we must force traditional ARM mode.
24 JAMVM_CONF_ENV
= CFLAGS
="$(TARGET_CFLAGS) -marm"
27 # Needed for autoreconf
28 define JAMVM_CREATE_M4_DIR
32 JAMVM_POST_PATCH_HOOKS
+= JAMVM_CREATE_M4_DIR
34 $(eval
$(autotools-package
))