python-pyasn: bump to version 1.6.0b1
[buildroot-gz.git] / package / jamvm / jamvm.mk
blobee80c80b2f379180bfab1fc8b3e027905197b34b
1 ################################################################################
3 # jamvm
5 ################################################################################
7 JAMVM_VERSION = 2.0.0
8 JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
9 JAMVM_LICENSE = GPLv2+
10 JAMVM_LICENSE_FILES = COPYING
11 JAMVM_DEPENDENCIES = zlib classpath
12 # For 0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch
13 JAMVM_AUTORECONF = YES
14 # int inlining seems to crash jamvm, don't build shared version of internal lib
15 JAMVM_CONF_OPTS = \
16 --with-classpath-install-dir=/usr \
17 --disable-int-inlining \
18 --disable-shared \
19 --without-pic
21 # jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
22 # so we must force traditional ARM mode.
23 ifeq ($(BR2_arm),y)
24 JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
25 endif
27 # Needed for autoreconf
28 define JAMVM_CREATE_M4_DIR
29 mkdir -p $(@D)/m4
30 endef
32 JAMVM_POST_PATCH_HOOKS += JAMVM_CREATE_M4_DIR
34 $(eval $(autotools-package))