1 ################################################################################
5 ################################################################################
7 LIBICONV_VERSION
= 1.14
8 LIBICONV_SITE
= $(BR2_GNU_MIRROR
)/libiconv
9 LIBICONV_INSTALL_STAGING
= YES
10 LIBICONV_LICENSE
= GPLv3
+ (iconv program
), LGPLv2
+ (library
)
11 LIBICONV_LICENSE_FILES
= COPYING COPYING.LIB
13 # Don't build the preloadable library, as we don't need it (it's only
14 # for LD_PRELOAD to replace glibc's iconv, but we never build libiconv
15 # when glibc is used). And it causes problems for static only builds.
16 define LIBICONV_DISABLE_PRELOAD
17 $(SED
) '/preload/d' $(@D
)/Makefile.in
19 LIBICONV_PRE_CONFIGURE_HOOKS
+= LIBICONV_DISABLE_PRELOAD
21 $(eval
$(autotools-package
))
23 # Configurations where the toolchain supports locales and the libiconv
24 # package is enabled are incorrect, because the toolchain already
25 # provides libiconv functionality, and having both confuses packages.
26 ifeq ($(BR2_PACKAGE_LIBICONV
)$(BR2_ENABLE_LOCALE
),yy
)
27 $(error Libiconv should never be enabled when the toolchain supports locales. Report this failure to Buildroot developers
)