1 ################################################################################
5 ################################################################################
7 # See note below when updating Erlang
9 ERLANG_SITE
= http
://www.erlang.org
/download
10 ERLANG_SOURCE
= otp_src_
$(ERLANG_VERSION
).
tar.gz
11 ERLANG_DEPENDENCIES
= host-erlang
13 ERLANG_LICENSE
= Apache-2.0
14 ERLANG_LICENSE_FILES
= LICENSE.txt
15 ERLANG_INSTALL_STAGING
= YES
17 # Patched erts/aclocal.m4
18 ERLANG_AUTORECONF
= YES
20 # Whenever updating Erlang, this value should be updated as well, to the
21 # value of EI_VSN in the file lib/erl_interface/vsn.mk
24 # The configure checks for these functions fail incorrectly
25 ERLANG_CONF_ENV
= ac_cv_func_isnan
=yes ac_cv_func_isinf
=yes
27 # Set erl_xcomp variables. See xcomp/erl-xcomp.conf.template
29 ERLANG_CONF_ENV
+= erl_xcomp_sysroot
=$(STAGING_DIR
)
31 ERLANG_CONF_OPTS
= --without-javac
33 # erlang uses openssl for all things crypto. Since the host tools (such as
34 # rebar) uses crypto, we need to build host-erlang with support for openssl.
35 HOST_ERLANG_DEPENDENCIES
= host-openssl
36 HOST_ERLANG_CONF_OPTS
= --without-javac
--with-ssl
=$(HOST_DIR
)/usr
38 HOST_ERLANG_CONF_OPTS
+= --without-termcap
40 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),)
41 ERLANG_CONF_OPTS
+= --disable-threads
44 ifeq ($(BR2_PACKAGE_NCURSES
),y
)
45 ERLANG_CONF_OPTS
+= --with-termcap
46 ERLANG_DEPENDENCIES
+= ncurses
48 ERLANG_CONF_OPTS
+= --without-termcap
51 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
52 ERLANG_CONF_OPTS
+= --with-ssl
53 ERLANG_DEPENDENCIES
+= openssl
55 ERLANG_CONF_OPTS
+= --without-ssl
58 ifeq ($(BR2_PACKAGE_UNIXODBC
),y
)
59 ERLANG_DEPENDENCIES
+= unixodbc
62 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
63 ERLANG_CONF_OPTS
+= --enable-shared-zlib
64 ERLANG_DEPENDENCIES
+= zlib
67 ifeq ($(BR2_PACKAGE_ERLANG_SMP
),)
68 ERLANG_CONF_OPTS
+= --disable-smp-support
71 # Remove source, example, gs and wx files from staging and target.
72 ERLANG_REMOVE_PACKAGES
= gs wx
74 ifneq ($(BR2_PACKAGE_ERLANG_MEGACO
),y
)
75 ERLANG_REMOVE_PACKAGES
+= megaco
78 define ERLANG_REMOVE_STAGING_UNUSED
79 for package in
$(ERLANG_REMOVE_PACKAGES
); do \
80 rm -rf
$(STAGING_DIR
)/usr
/lib
/erlang
/lib
/$${package}-*; \
84 define ERLANG_REMOVE_TARGET_UNUSED
85 find
$(TARGET_DIR
)/usr
/lib
/erlang
-type d
-name src
-prune
-exec
rm -rf
{} \
;
86 find
$(TARGET_DIR
)/usr
/lib
/erlang
-type d
-name examples
-prune
-exec
rm -rf
{} \
;
87 for package in
$(ERLANG_REMOVE_PACKAGES
); do \
88 rm -rf
$(TARGET_DIR
)/usr
/lib
/erlang
/lib
/$${package}-*; \
92 ERLANG_POST_INSTALL_STAGING_HOOKS
+= ERLANG_REMOVE_STAGING_UNUSED
93 ERLANG_POST_INSTALL_TARGET_HOOKS
+= ERLANG_REMOVE_TARGET_UNUSED
95 $(eval
$(autotools-package
))
96 $(eval
$(host-autotools-package
))