1 ################################################################################
5 ################################################################################
8 OLA_SOURCE
= ola-
$(OLA_VERSION
).
tar.gz
9 OLA_SITE
= https
://github.com
/OpenLightingProject
/ola
/releases
/download
/$(OLA_VERSION
)
10 OLA_LICENSE
= LGPLv2.1
+ (libola
, libolacommon
, Python bindings
), GPLv2
+ (libolaserver
, olad
, Python examples and tests
)
11 OLA_LICENSE_FILES
= LICENCE GPL LGPL
12 OLA_INSTALL_STAGING
= YES
15 # util-linux provides uuid lib
16 OLA_DEPENDENCIES
= protobuf util-linux host-bison host-flex host-ola
19 ac_cv_have_pymod_google_protobuf
=yes \
23 --disable-root-check \
25 --disable-fatal-warnings \
26 --with-ola-protoc-plugin
=$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
28 HOST_OLA_DEPENDENCIES
= host-util-linux host-protobuf
30 # When building the host part, disable as much as possible to speed up
31 # the configure step and avoid missing host dependencies.
32 HOST_OLA_CONF_OPTS
= \
33 --disable-all-plugins \
42 --disable-doxygen-html \
43 --disable-doxygen-doc \
44 --disable-fatal-warnings
46 # On the host side, we only need ola_protoc_plugin, so build and install this
48 HOST_OLA_MAKE_OPTS
= protoc
/ola_protoc_plugin
49 define HOST_OLA_INSTALL_CMDS
50 $(INSTALL
) -D
-m
0755 $(@D
)/protoc
/ola_protoc_plugin
$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
53 # sets where to find python libs built for target and required by ola
54 OLA_CONF_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
55 OLA_MAKE_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
57 ## OLA Bindings and Interface selections
59 ifeq ($(BR2_PACKAGE_OLA_WEB
),y
)
60 OLA_CONF_OPTS
+= --enable-http
61 OLA_DEPENDENCIES
+= libmicrohttpd
63 OLA_CONF_OPTS
+= --disable-http
66 ifeq ($(BR2_PACKAGE_OLA_SLP
),y
)
67 OLA_CONF_OPTS
+= --enable-slp
69 OLA_CONF_OPTS
+= --disable-slp
72 ifeq ($(BR2_PACKAGE_OLA_PYTHON_BINDINGS
),y
)
73 OLA_CONF_OPTS
+= --enable-python-libs
74 OLA_DEPENDENCIES
+= python python-protobuf
76 OLA_CONF_OPTS
+= --disable-python-libs
79 ## OLA Examples and Tests
81 ifeq ($(BR2_PACKAGE_OLA_EXAMPLES
),y
)
82 OLA_CONF_OPTS
+= --enable-examples
83 OLA_DEPENDENCIES
+= ncurses
85 OLA_CONF_OPTS
+= --disable-examples
88 ifeq ($(BR2_PACKAGE_OLA_RDM_TESTS
),y
)
89 OLA_CONF_OPTS
+= --enable-rdm-tests
91 OLA_CONF_OPTS
+= --disable-rdm-tests
94 ## OLA Plugin selections
96 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_E131
),y
)
97 OLA_CONF_OPTS
+= --enable-e131
99 OLA_CONF_OPTS
+= --disable-e131
102 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ARTNET
),y
)
103 OLA_CONF_OPTS
+= --enable-artnet
105 OLA_CONF_OPTS
+= --disable-artnet
108 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OPENDMX
),y
)
109 OLA_CONF_OPTS
+= --enable-opendmx
111 OLA_CONF_OPTS
+= --disable-opendmx
114 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_DUMMY
),y
)
115 OLA_CONF_OPTS
+= --enable-dummy
117 OLA_CONF_OPTS
+= --disable-dummy
120 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ESPNET
),y
)
121 OLA_CONF_OPTS
+= --enable-espnet
123 OLA_CONF_OPTS
+= --disable-espnet
126 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_KINET
),y
)
127 OLA_CONF_OPTS
+= --enable-kinet
129 OLA_CONF_OPTS
+= --disable-kinet
132 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OSC
),y
)
133 OLA_CONF_OPTS
+= --enable-osc
134 OLA_DEPENDENCIES
+= liblo
136 OLA_CONF_OPTS
+= --disable-osc
139 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_MILINT
),y
)
140 OLA_CONF_OPTS
+= --enable-milinst
142 OLA_CONF_OPTS
+= --disable-milinst
145 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_PATHPORT
),y
)
146 OLA_CONF_OPTS
+= --enable-pathport
148 OLA_CONF_OPTS
+= --disable-pathport
151 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SANDNET
),y
)
152 OLA_CONF_OPTS
+= --enable-sandnet
154 OLA_CONF_OPTS
+= --disable-sandnet
157 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SHOWNET
),y
)
158 OLA_CONF_OPTS
+= --enable-shownet
160 OLA_CONF_OPTS
+= --disable-shownet
163 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_STAGEPROFI
),y
)
164 OLA_CONF_OPTS
+= --enable-stageprofi
--enable-libusb
166 OLA_CONF_OPTS
+= --disable-stageprofi
169 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_USBPRO
),y
)
170 OLA_CONF_OPTS
+= --enable-usbpro
--enable-libusb
172 OLA_CONF_OPTS
+= --disable-usbpro
175 $(eval
$(autotools-package
))
176 $(eval
$(host-autotools-package
))