toolchain/external: bump Linaro ARMeb to 2016.05 for i686 hosts
[buildroot-gz.git] / package / ola / ola.mk
blob75ab25e164c29c2d57f50c92eda66d7fa6ad251f
1 ################################################################################
3 # ola
5 ################################################################################
7 OLA_VERSION = 0.10.2
8 OLA_SOURCE = ola-$(OLA_VERSION).tar.gz
9 OLA_SITE = https://github.com/OpenLightingProject/ola/releases/download/$(OLA_VERSION)
10 OLA_LICENSE = LGPLv2.1+ (libola, libolacommon, Python bindings), GPLv2+ (libolaserver, olad, Python examples and tests)
11 OLA_LICENSE_FILES = LICENCE GPL LGPL
12 OLA_INSTALL_STAGING = YES
13 OLA_AUTORECONF = YES
15 # util-linux provides uuid lib
16 OLA_DEPENDENCIES = protobuf util-linux host-bison host-flex host-ola
18 OLA_CONF_OPTS = \
19 ac_cv_have_pymod_google_protobuf=yes \
20 --disable-gcov \
21 --disable-tcmalloc \
22 --disable-unittests \
23 --disable-root-check \
24 --disable-java-libs \
25 --disable-fatal-warnings \
26 --with-ola-protoc-plugin=$(HOST_DIR)/usr/bin/ola_protoc_plugin
28 HOST_OLA_DEPENDENCIES = host-util-linux host-protobuf
30 # When building the host part, disable as much as possible to speed up
31 # the configure step and avoid missing host dependencies.
32 HOST_OLA_CONF_OPTS = \
33 --disable-all-plugins \
34 --disable-slp \
35 --disable-osc \
36 --disable-uart \
37 --disable-libusb \
38 --disable-libftdi \
39 --disable-http \
40 --disable-examples \
41 --disable-unittests \
42 --disable-doxygen-html \
43 --disable-doxygen-doc \
44 --disable-fatal-warnings
46 # On the host side, we only need ola_protoc_plugin, so build and install this
47 # only.
48 HOST_OLA_MAKE_OPTS = protoc/ola_protoc_plugin
49 define HOST_OLA_INSTALL_CMDS
50 $(INSTALL) -D -m 0755 $(@D)/protoc/ola_protoc_plugin $(HOST_DIR)/usr/bin/ola_protoc_plugin
51 endef
53 # sets where to find python libs built for target and required by ola
54 OLA_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
55 OLA_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
57 ## OLA Bindings and Interface selections
59 ifeq ($(BR2_PACKAGE_OLA_WEB),y)
60 OLA_CONF_OPTS += --enable-http
61 OLA_DEPENDENCIES += libmicrohttpd
62 else
63 OLA_CONF_OPTS += --disable-http
64 endif
66 ifeq ($(BR2_PACKAGE_OLA_SLP),y)
67 OLA_CONF_OPTS += --enable-slp
68 else
69 OLA_CONF_OPTS += --disable-slp
70 endif
72 ifeq ($(BR2_PACKAGE_OLA_PYTHON_BINDINGS),y)
73 OLA_CONF_OPTS += --enable-python-libs
74 OLA_DEPENDENCIES += python python-protobuf
75 else
76 OLA_CONF_OPTS += --disable-python-libs
77 endif
79 ## OLA Examples and Tests
81 ifeq ($(BR2_PACKAGE_OLA_EXAMPLES),y)
82 OLA_CONF_OPTS += --enable-examples
83 OLA_DEPENDENCIES += ncurses
84 else
85 OLA_CONF_OPTS += --disable-examples
86 endif
88 ifeq ($(BR2_PACKAGE_OLA_RDM_TESTS),y)
89 OLA_CONF_OPTS += --enable-rdm-tests
90 else
91 OLA_CONF_OPTS += --disable-rdm-tests
92 endif
94 ## OLA Plugin selections
96 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_E131),y)
97 OLA_CONF_OPTS += --enable-e131
98 else
99 OLA_CONF_OPTS += --disable-e131
100 endif
102 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ARTNET),y)
103 OLA_CONF_OPTS += --enable-artnet
104 else
105 OLA_CONF_OPTS += --disable-artnet
106 endif
108 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OPENDMX),y)
109 OLA_CONF_OPTS += --enable-opendmx
110 else
111 OLA_CONF_OPTS += --disable-opendmx
112 endif
114 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_DUMMY),y)
115 OLA_CONF_OPTS += --enable-dummy
116 else
117 OLA_CONF_OPTS += --disable-dummy
118 endif
120 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ESPNET),y)
121 OLA_CONF_OPTS += --enable-espnet
122 else
123 OLA_CONF_OPTS += --disable-espnet
124 endif
126 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_KINET),y)
127 OLA_CONF_OPTS += --enable-kinet
128 else
129 OLA_CONF_OPTS += --disable-kinet
130 endif
132 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OSC),y)
133 OLA_CONF_OPTS += --enable-osc
134 OLA_DEPENDENCIES += liblo
135 else
136 OLA_CONF_OPTS += --disable-osc
137 endif
139 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_MILINT),y)
140 OLA_CONF_OPTS += --enable-milinst
141 else
142 OLA_CONF_OPTS += --disable-milinst
143 endif
145 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_PATHPORT),y)
146 OLA_CONF_OPTS += --enable-pathport
147 else
148 OLA_CONF_OPTS += --disable-pathport
149 endif
151 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SANDNET),y)
152 OLA_CONF_OPTS += --enable-sandnet
153 else
154 OLA_CONF_OPTS += --disable-sandnet
155 endif
157 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SHOWNET),y)
158 OLA_CONF_OPTS += --enable-shownet
159 else
160 OLA_CONF_OPTS += --disable-shownet
161 endif
163 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_STAGEPROFI),y)
164 OLA_CONF_OPTS += --enable-stageprofi --enable-libusb
165 else
166 OLA_CONF_OPTS += --disable-stageprofi
167 endif
169 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_USBPRO),y)
170 OLA_CONF_OPTS += --enable-usbpro --enable-libusb
171 else
172 OLA_CONF_OPTS += --disable-usbpro
173 endif
175 $(eval $(autotools-package))
176 $(eval $(host-autotools-package))