xorg-server: not available with musl on ARM
[buildroot-gz.git] / package / micropython / micropython.mk
blob2f47ad899625ffcd11e1cb6b6d5d3b4d806ad987
1 ################################################################################
3 # micropython
5 ################################################################################
7 MICROPYTHON_VERSION = v1.8.3
8 MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
9 MICROPYTHON_LICENSE = MIT
10 MICROPYTHON_LICENSE_FILES = LICENSE
11 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
12 MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch \
13 https://github.com/micropython/micropython/commit/a50b26e4b00ed094aa1ac74eac2fc2d8eb9ea1ed.patch
15 # Use fallback implementation for exception handling on architectures that don't
16 # have explicit support.
17 ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
18 MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
19 endif
21 # When building from a tarball we don't have some of the dependencies that are in
22 # the git repository as submodules
23 MICROPYTHON_MAKE_OPTS = MICROPY_PY_BTREE=0
24 MICROPYTHON_MAKE_OPTS += MICROPY_PY_USSL=0
26 define MICROPYTHON_BUILD_CMDS
27 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/unix \
28 $(MICROPYTHON_MAKE_OPTS) \
29 CROSS_COMPILE=$(TARGET_CROSS) \
30 CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS)
31 endef
33 define MICROPYTHON_INSTALL_TARGET_CMDS
34 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/unix \
35 $(MICROPYTHON_MAKE_OPTS) \
36 DESTDIR=$(TARGET_DIR) \
37 PREFIX=$(TARGET_DIR)/usr \
38 install
39 endef
41 $(eval $(generic-package))