xorg-server: not available with musl on ARM
[buildroot-gz.git] / package / ncftp / ncftp.mk
blob5c88556a39d35bba10d5cada9941683b9b203dd0
1 ################################################################################
3 # ncftp
5 ################################################################################
7 NCFTP_VERSION = 3.2.6
8 NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.xz
9 NCFTP_SITE = ftp://ftp.ncftp.com/ncftp
10 NCFTP_TARGET_BINS = ncftp
11 NCFTP_LICENSE = Clarified Artistic License
12 NCFTP_LICENSE_FILES = doc/LICENSE.txt
14 NCFTP_DEPENDENCIES = host-autoconf
16 # The bundled configure script is generated by autoconf 2.13 and doesn't
17 # detect cross-compilation correctly. Therefore, we have to regenerate it.
18 # We need to pass -I because of the non-standard m4 directory name, and
19 # none of the other autotools are used, so the below is the easiest.
20 define NCFTP_RUN_AUTOCONF
21 (cd $(@D); $(HOST_DIR)/usr/bin/autoconf -I$(@D)/autoconf_local/)
22 endef
23 NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
25 ifeq ($(BR2_PACKAGE_NCFTP_GET),y)
26 NCFTP_TARGET_BINS += ncftpget
27 endif
29 ifeq ($(BR2_PACKAGE_NCFTP_PUT),y)
30 NCFTP_TARGET_BINS += ncftpput
31 endif
33 ifeq ($(BR2_PACKAGE_NCFTP_LS),y)
34 NCFTP_TARGET_BINS += ncftpls
35 endif
37 ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
38 NCFTP_TARGET_BINS += ncftpbatch
39 NCFTP_INSTALL_NCFTP_BATCH = \
40 ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
41 endif
43 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
44 NCFTP_TARGET_BINS += ncftpbookmarks
45 NCFTP_DEPENDENCIES += ncurses
46 endif
48 define NCFTP_INSTALL_TARGET_CMDS
49 $(INSTALL) -m 0755 $(addprefix $(NCFTP_DIR)/bin/, $(NCFTP_TARGET_BINS)) $(TARGET_DIR)/usr/bin
50 $(NCFTP_INSTALL_NCFTP_BATCH)
51 endef
53 $(eval $(autotools-package))