1 ################################################################################
5 ################################################################################
7 ALLJOYN_BASE_REV
= 16.04
8 ALLJOYN_BASE_VERSION
= $(ALLJOYN_BASE_REV
).00
10 https
://mirrors.kernel.org
/allseenalliance
/alljoyn
/$(ALLJOYN_BASE_REV
)
11 # See https://allseenalliance.org/alliance/ip-policy
12 ALLJOYN_BASE_LICENSE
= ISC
14 ALLJOYN_BASE_DEPENDENCIES
= host-scons alljoyn openssl
15 ALLJOYN_BASE_INSTALL_STAGING
= YES
17 ALLJOYN_BASE_CRYPTO
= openssl
19 # AllJoyn can be compiled in debug or release mode. By default,
20 # AllJoyn is built in debug mode.
21 ALLJOYN_BASE_VARIANT
= release
23 ALLJOYN_BASE_BINDINGS
= c
,cpp
25 # By setting openwrt for OS and CPU, AllJoyn cross-compilation can be finely
26 # tuned through TARGET_xxx options. All TARGET_xxx variables must be defined
27 # otherwise compilation will fail.
28 # CROSS_COMPILE option should not be used as it works only for linux/ARM.
29 ALLJOYN_BASE_OS
= openwrt
30 ALLJOYN_BASE_CPU
= openwrt
32 # AllJoyn install everything in this relative path
33 ALLJOYN_BASE_DISTDIR
= \
34 build
/$(ALLJOYN_OS
)/$(ALLJOYN_CPU
)/$(ALLJOYN_VARIANT
)/dist
36 ALLJOYN_BASE_SCONS_OPTS
= \
39 OS
=$(ALLJOYN_BASE_OS
) \
40 CPU
=$(ALLJOYN_BASE_CPU
) \
41 VARIANT
=$(ALLJOYN_BASE_VARIANT
) \
43 CRYPTO
=$(ALLJOYN_BASE_CRYPTO
) \
44 BINDINGS
=$(ALLJOYN_BASE_BINDINGS
) \
45 ALLJOYN_DISTDIR
="$(STAGING_DIR)"\
46 TARGET_CFLAGS
="$(TARGET_CFLAGS)" \
47 TARGET_CPPFLAGS
="$(TARGET_CPPFLAGS)" \
48 TARGET_LINKFLAGS
="$(TARGET_LINKFLAGS)" \
49 TARGET_CC
="$(TARGET_CC)" \
50 TARGET_CXX
="$(TARGET_CXX)" \
51 TARGET_LD
="$(TARGET_LD)" \
52 TARGET_LINK
="$(TARGET_CXX)" \
53 TARGET_AR
="$(TARGET_AR)" \
54 TARGET_RANLIB
="$(TARGET_RANLIB)" \
55 TARGET_PATH
="$(BR_PATH)"
57 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_CONTROLPANEL
), y
)
58 ALLJOYN_BASE_TARGETS
+= controlpanel
61 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_NOTIFICATION
), y
)
62 ALLJOYN_BASE_TARGETS
+= notification
65 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_ONBOARDING
), y
)
66 ALLJOYN_BASE_TARGETS
+= onboarding
69 define ALLJOYN_BASE_BUILD_CMDS
70 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
71 cd
$(@D
)/$(target
); $(SCONS
) $(ALLJOYN_BASE_SCONS_OPTS
)
75 define ALLJOYN_BASE_INSTALL_STAGING_CMDS
76 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
77 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/lib
/lib
* \
78 $(STAGING_DIR
)/usr
/lib
/
79 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/inc
/* \
80 $(STAGING_DIR
)/usr
/include/
84 define ALLJOYN_BASE_INSTALL_TARGET_CMDS
85 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
86 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/lib
/lib
* \
87 $(TARGET_DIR
)/usr
/lib
/
91 $(eval
$(generic-package
))