1 ################################################################################
5 ################################################################################
7 C_PERIPHERY_VERSION
= v1.0
.3
8 C_PERIPHERY_SITE
= $(call github
,vsergeev
,c-periphery
,$(C_PERIPHERY_VERSION
))
9 C_PERIPHERY_INSTALL_STAGING
= YES
10 # only a static library
11 C_PERIPHERY_INSTALL_TARGET
= NO
12 C_PERIPHERY_LICENSE
= MIT
13 C_PERIPHERY_LICENSE_FILES
= LICENSE
15 define C_PERIPHERY_BUILD_CMDS
16 $(TARGET_MAKE_ENV
) $(TARGET_CONFIGURE_OPTS
) $(MAKE
) -C
$(@D
)
19 # There is no 'install' rule in the Makefile, so we handle things
21 define C_PERIPHERY_INSTALL_STAGING_CMDS
22 $(INSTALL
) -D
-m
0644 $(@D
)/periphery.a
$(STAGING_DIR
)/usr
/lib
/libc-periphery.a
23 mkdir
-p
$(STAGING_DIR
)/usr
/include/c-periphery
/
24 cp
-dpfr
$(@D
)/src
/*.h
$(STAGING_DIR
)/usr
/include/c-periphery
/
27 $(eval
$(generic-package
))