1 ################################################################################
5 ################################################################################
7 CLAMAV_VERSION
= 0.99.2
8 CLAMAV_SITE
= https
://www.clamav.net
/downloads
/production
10 CLAMAV_LICENSE_FILES
= COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11 COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12 COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES
= \
18 $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext
)
20 # mmap cannot be detected when cross-compiling, needed for mempool support
22 ac_cv_c_mmap_private
=yes \
25 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
27 --with-dbdir
=/var
/lib
/clamav \
28 --with-ltdl-include
=$(STAGING_DIR
)/usr
/include \
29 --with-ltdl-lib
=$(STAGING_DIR
)/usr
/lib \
30 --with-openssl
=$(STAGING_DIR
)/usr \
31 --with-zlib
=$(STAGING_DIR
)/usr \
32 --disable-zlib-vcheck \
41 ifeq ($(BR2_PACKAGE_BZIP2
),y
)
42 CLAMAV_DEPENDENCIES
+= bzip2
43 # autodetection gets confused if host has bzip2, so force it
45 ac_cv_libbz2_libs
=-lbz2 \
46 ac_cv_libbz2_ltlibs
=-lbz2
48 CLAMAV_CONF_OPTS
+= --disable-bzip2
51 ifeq ($(BR2_PACKAGE_JSON_C
),y
)
52 CLAMAV_CONF_OPTS
+= --with-libjson
=$(STAGING_DIR
)/usr
53 CLAMAV_DEPENDENCIES
+= json-c
55 CLAMAV_CONF_OPTS
+= --without-libjson
58 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
59 CLAMAV_CONF_OPTS
+= --with-xml
=$(STAGING_DIR
)/usr
60 CLAMAV_DEPENDENCIES
+= libxml2
62 CLAMAV_CONF_OPTS
+= --disable-xml
65 ifeq ($(BR2_PACKAGE_LIBCURL
),y
)
66 CLAMAV_CONF_OPTS
+= --with-libcurl
=$(STAGING_DIR
)/usr
67 CLAMAV_DEPENDENCIES
+= libcurl
69 CLAMAV_CONF_OPTS
+= --without-libcurl
72 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
73 CLAMAV_CONF_OPTS
+= --with-iconv
74 CLAMAV_DEPENDENCIES
+= libiconv
76 CLAMAV_CONF_OPTS
+= --without-iconv
79 ifeq ($(BR2_PACKAGE_PCRE
),y
)
80 CLAMAV_CONF_OPTS
+= --with-pcre
=$(STAGING_DIR
)/usr
81 CLAMAV_DEPENDENCIES
+= pcre
83 CLAMAV_CONF_OPTS
+= --without-pcre
86 $(eval
$(autotools-package
))