1 ################################################################################
5 ################################################################################
7 CWIID_VERSION
= fadf11e89b579bcc0336a0692ac15c93785f3f82
8 CWIID_SITE
= $(call github
,abstrakraft
,cwiid
,$(CWIID_VERSION
))
10 CWIID_LICENSE_FILES
= COPYING
12 CWIID_AUTORECONF
= YES
13 CWIID_INSTALL_STAGING
= YES
15 CWIID_DEPENDENCIES
= host-pkgconf host-bison host-flex bluez_utils
17 # Disable python support. This disables the 2 following things:
18 # - wminput Python plugin support
19 # - cwiid Python module
20 CWIID_CONF_OPTS
= --without-python
--disable-ldconfig
22 ifeq ($(BR2_PACKAGE_CWIID_WMGUI
),y
)
23 CWIID_DEPENDENCIES
+= libgtk2 libglib2
24 CWIID_CONF_OPTS
+= --enable-wmgui
26 CWIID_CONF_OPTS
+= --disable-wmgui
29 $(eval
$(autotools-package
))