1 ################################################################################
5 ################################################################################
7 DBUS_CPP_VERSION
= 0.9.0
8 DBUS_CPP_SITE
= http
://downloads.sourceforge.net
/project
/dbus-cplusplus
/dbus-c
++/$(DBUS_CPP_VERSION
)
9 DBUS_CPP_SOURCE
= libdbus-c
++-$(DBUS_CPP_VERSION
).
tar.gz
10 DBUS_CPP_INSTALL_STAGING
= YES
11 # expat is required for the tools irrespective of dbus xml backend
12 DBUS_CPP_DEPENDENCIES
= host-dbus-cpp host-pkgconf dbus expat
13 HOST_DBUS_CPP_DEPENDENCIES
= host-pkgconf host-dbus host-expat
14 DBUS_CPP_CONF_OPTS
= \
17 --disable-doxygen-docs \
18 --with-build-libdbus-cxx
=$(HOST_DBUS_CPP_BUILDDIR
)
19 HOST_DBUS_CPP_CONF_OPTS
= \
22 --disable-doxygen-docs \
25 DBUS_CPP_AUTORECONF
= YES
26 DBUS_CPP_LICENSE
= LGPLv2.1
+
27 DBUS_CPP_LICENSE_FILES
= COPYING
29 ifeq ($(BR2_PACKAGE_EFL
),y
)
30 DBUS_CPP_CONF_OPTS
+= --enable-ecore
31 DBUS_CPP_DEPENDENCIES
+= efl
33 DBUS_CPP_CONF_OPTS
+= --disable-ecore
36 ifeq ($(BR2_PACKAGE_LIBGLIB2
),y
)
37 DBUS_CPP_CONF_OPTS
+= --enable-glib
38 DBUS_CPP_DEPENDENCIES
+= libglib2
40 DBUS_CPP_CONF_OPTS
+= --disable-glib
43 $(eval
$(autotools-package
))
44 $(eval
$(host-autotools-package
))