1 ################################################################################
5 ################################################################################
7 DHCPCD_VERSION
= 6.11.5
8 DHCPCD_SOURCE
= dhcpcd-
$(DHCPCD_VERSION
).
tar.xz
9 DHCPCD_SITE
= http
://roy.marples.name
/downloads
/dhcpcd
10 DHCPCD_DEPENDENCIES
= host-pkgconf
11 DHCPCD_LICENSE
= BSD-2c
12 DHCPCD_LICENSE_FILES
= dhcpcd.c
14 ifeq ($(BR2_STATIC_LIBS
),y
)
15 DHCPCD_CONFIG_OPTS
+= --enable-static
18 ifeq ($(BR2_USE_MMU
),)
19 DHCPCD_CONFIG_OPTS
+= --disable-fork
22 define DHCPCD_CONFIGURE_CMDS
24 $(TARGET_CONFIGURE_OPTS
) .
/configure \
26 --libexecdir
=/lib
/dhcpcd \
27 $(DHCPCD_CONFIG_OPTS
) )
30 define DHCPCD_BUILD_CMDS
31 $(TARGET_MAKE_ENV
) $(MAKE
) \
35 define DHCPCD_INSTALL_TARGET_CMDS
36 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) install DESTDIR
=$(TARGET_DIR
)
39 # NOTE: Even though this package has a configure script, it is not generated
40 # using the autotools, so we have to use the generic package infrastructure.
42 $(eval
$(generic-package
))