1 ################################################################################
5 ################################################################################
7 DTV_SCAN_TABLES_VERSION
= ceb11833b35f05813b1f0397a60e0f3b99430aab
8 DTV_SCAN_TABLES_SITE
= http
://git.linuxtv.org
/cgit.cgi
/dtv-scan-tables.git
9 DTV_SCAN_TABLES_SITE_METHOD
= git
11 # This package only contains the transponders data. This is not a 'work'
12 # as per traditional copyright, but just a collection of 'facts', so there's
13 # probably no license to apply to these data files.
14 # However, the package prominently contains the COPYING and COPYING.LIB
15 # license files (respectively for the GPLv2 and the LGPLv2.1), so we use
16 # that as the licensing information.
17 DTV_SCAN_TABLES_LICENSE
= GPLv2
, LGPLv2.1
18 DTV_SCAN_TABLES_LICENSE_FILES
= COPYING COPYING.LGPL
20 # In order to avoid issues with file name encodings, we rename the
21 # only dtv-scan-tables file that has non-ASCII characters to have a
22 # name using only ASCII characters (pl-Krosno_Sucha_Gora)
23 define DTV_SCAN_TABLES_FIX_NONASCII_FILENAMES
24 mv
$(@D
)/dvb-t
/pl-Krosno_Sucha
* $(@D
)/dvb-t
/pl-Krosno_Sucha_Gora
27 DTV_SCAN_TABLES_POST_PATCH_HOOKS
+= DTV_SCAN_TABLES_FIX_NONASCII_FILENAMES
29 define DTV_SCAN_TABLES_INSTALL_TARGET_CMDS
30 for f in atsc dvb-c dvb-s dvb-t
; do \
31 $(INSTALL
) -d
-m
0755 $(TARGET_DIR
)/usr
/share
/dvb
/$$f; \
32 $(INSTALL
) $(@D
)/$$f/* $(TARGET_DIR
)/usr
/share
/dvb
/$$f; \
36 $(eval
$(generic-package
))