board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / irssi / irssi.mk
blobdfb1e2878002455f7f7f6bf9567762edf9c966a6
1 ################################################################################
3 # irssi
5 ################################################################################
7 IRSSI_VERSION = 1.0.2
8 IRSSI_SOURCE = irssi-$(IRSSI_VERSION).tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE = https://github.com/irssi/irssi/releases/download/$(IRSSI_VERSION)
12 IRSSI_LICENSE = GPLv2+
13 IRSSI_LICENSE_FILES = COPYING
14 IRSSI_DEPENDENCIES = host-pkgconf libglib2 ncurses openssl
16 # We're patching configure.ac, so we need to autoreconf
17 IRSSI_AUTORECONF = YES
19 IRSSI_CONF_OPTS = \
20 --disable-glibtest \
21 --with-ncurses=$(STAGING_DIR)/usr \
22 --without-perl
24 ifeq ($(BR2_PACKAGE_IRSSI_PROXY),y)
25 IRSSI_CONF_OPTS += --with-proxy
26 # If shared libs are disabled, 'proxy' has to go in the list of built-in
27 # modules.
28 ifeq ($(BR2_STATIC_LIBS),y)
29 IRSSI_CONF_OPTS += --with-modules=proxy
30 endif
31 else
32 IRSSI_CONF_OPTS += --without-proxy
33 endif # proxy
35 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR),y)
36 IRSSI_CONF_OPTS += --enable-true-color
37 else
38 IRSSI_CONF_OPTS += --disable-true-color
39 endif
41 # Cross-compiling irssi with the perl interpreter enabled doesn't work
42 # yet. So, remove scripts as they are useless in that case.
43 define IRSSI_REMOVE_SCRIPTS
44 rm -rf $(TARGET_DIR)/usr/share/irssi/scripts/
45 endef
47 IRSSI_POST_INSTALL_TARGET_HOOKS += IRSSI_REMOVE_SCRIPTS
49 $(eval $(autotools-package))