1 ################################################################################
5 ################################################################################
8 IRSSI_SOURCE
= irssi-
$(IRSSI_VERSION
).
tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE
= https
://github.com
/irssi
/irssi
/releases
/download
/$(IRSSI_VERSION
)
12 IRSSI_LICENSE
= GPLv2
+
13 IRSSI_LICENSE_FILES
= COPYING
14 IRSSI_DEPENDENCIES
= host-pkgconf libglib2 ncurses openssl
16 # We're patching configure.ac, so we need to autoreconf
17 IRSSI_AUTORECONF
= YES
21 --with-ncurses
=$(STAGING_DIR
)/usr \
24 ifeq ($(BR2_PACKAGE_IRSSI_PROXY
),y
)
25 IRSSI_CONF_OPTS
+= --with-proxy
26 # If shared libs are disabled, 'proxy' has to go in the list of built-in
28 ifeq ($(BR2_STATIC_LIBS
),y
)
29 IRSSI_CONF_OPTS
+= --with-modules
=proxy
32 IRSSI_CONF_OPTS
+= --without-proxy
35 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR
),y
)
36 IRSSI_CONF_OPTS
+= --enable-true-color
38 IRSSI_CONF_OPTS
+= --disable-true-color
41 # Cross-compiling irssi with the perl interpreter enabled doesn't work
42 # yet. So, remove scripts as they are useless in that case.
43 define IRSSI_REMOVE_SCRIPTS
44 rm -rf
$(TARGET_DIR
)/usr
/share
/irssi
/scripts
/
47 IRSSI_POST_INSTALL_TARGET_HOOKS
+= IRSSI_REMOVE_SCRIPTS
49 $(eval
$(autotools-package
))