board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / linphone / linphone.mk
blobdf804907e8f67f246353b0e357f173e14893de49
1 ################################################################################
3 # linphone
5 ################################################################################
7 LINPHONE_VERSION_MAJOR = 3.6
8 LINPHONE_VERSION = $(LINPHONE_VERSION_MAJOR).1
9 LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/$(LINPHONE_VERSION_MAJOR).x/sources
10 LINPHONE_CONF_OPTS = \
11 --disable-strict --disable-video
12 # configure is out of sync causing deplibs linking issues
13 LINPHONE_AUTORECONF = YES
14 LINPHONE_INSTALL_STAGING = YES
15 LINPHONE_DEPENDENCIES = host-pkgconf libeXosip2 speex
16 LINPHONE_LICENSE = GPLv2+
17 LINPHONE_LICENSE_FILES = COPYING
18 LINPHONE_PATCH = \
19 https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav9.patch \
20 https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav10.patch \
21 https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav11.patch \
22 https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/ffmpeg_2.9.patch
24 ifeq ($(BR2_arc),y)
25 # toolchain __arc__ define conflicts with libosip2 source
26 LINPHONE_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
27 endif
29 ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
30 LINPHONE_CONF_OPTS += --enable-gtk_ui
31 LINPHONE_DEPENDENCIES += libgtk2
32 else
33 LINPHONE_CONF_OPTS += --disable-gtk_ui
34 endif
36 # needed for bundled mediastreamer2
37 LINPHONE_DEPENDENCIES += host-intltool host-gettext
39 ifeq ($(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yy)
40 LINPHONE_CONF_OPTS += --enable-alsa
41 LINPHONE_DEPENDENCIES += alsa-lib
42 else
43 LINPHONE_CONF_OPTS += --disable-alsa
44 endif
46 ifeq ($(BR2_PACKAGE_LIBV4L),y)
47 LINPHONE_CONF_OPTS += --enable-libv4l1 --enable-libv4l2
48 LINPHONE_DEPENDENCIES += libv4l
49 else
50 LINPHONE_CONF_OPTS += --disable-libv4l1 --disable-libv4l2
51 endif
53 $(eval $(autotools-package))