board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / lugaru / lugaru.mk
blob770493172ebb03daa72d87d04fe05eeb2659c72e
1 ################################################################################
3 # lugaru
5 ################################################################################
7 LUGARU_VERSION = 1.2
8 LUGARU_SITE = https://bitbucket.org/osslugaru/lugaru/downloads
9 LUGARU_SOURCE = lugaru-$(LUGARU_VERSION).tar.xz
11 LUGARU_LICENSE = GPLv2+, CC-BY-SA-3.0 (Wolfire and Slib assets), \
12 CC-BY-SA-4.0 (OSS Lugaru, Jendraz and Philtron R. assets)
13 LUGARU_LICENSE_FILES = COPYING.txt CONTENT-LICENSE.txt
15 LUGARU_DEPENDENCIES = host-pkgconf jpeg libgl libglu libpng libvorbis \
16 openal sdl2 zlib
18 # Avoid incompatible posix_memalign declaration on x86 and x86_64 with
19 # musl.
20 # https://gcc.gnu.org/ml/gcc-patches/2015-05/msg01425.html
21 ifeq ($(BR2_TOOLCHAIN_USES_MUSL):$(BR2_i386)$(BR2_x86_64),y:y)
22 define LUGARU_REMOVE_PEDANTIC
23 $(SED) 's% -pedantic%%' $(@D)/CMakeLists.txt
24 endef
25 LUGARU_POST_PATCH_HOOKS += LUGARU_REMOVE_PEDANTIC
26 endif
28 LUGARU_CONF_OPTS = -DSYSTEM_INSTALL=ON
30 $(eval $(cmake-package))