1 ################################################################################
5 ################################################################################
8 MUTT_SITE
= https
://bitbucket.org
/mutt
/mutt
/downloads
10 MUTT_LICENSE_FILES
= GPL
11 MUTT_DEPENDENCIES
= ncurses
12 MUTT_CONF_OPTS
= --disable-smtp
15 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
16 MUTT_DEPENDENCIES
+= libiconv
17 MUTT_CONF_OPTS
+= --enable-iconv
20 ifeq ($(BR2_PACKAGE_LIBIDN
),y
)
21 MUTT_DEPENDENCIES
+= libidn
22 MUTT_CONF_OPTS
+= --with-idn
24 MUTT_CONF_OPTS
+= --without-idn
27 ifeq ($(BR2_PACKAGE_MUTT_IMAP
),y
)
28 MUTT_CONF_OPTS
+= --enable-imap
30 MUTT_CONF_OPTS
+= --disable-imap
33 ifeq ($(BR2_PACKAGE_MUTT_POP3
),y
)
34 MUTT_CONF_OPTS
+= --enable-pop
36 MUTT_CONF_OPTS
+= --disable-pop
39 # SSL support is only used by imap or pop3 module
40 ifneq ($(BR2_PACKAGET_MUTT_IMAP
)$(BR2_PACKAGE_MUTT_POP3
),)
41 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
42 MUTT_DEPENDENCIES
+= openssl
43 MUTT_CONF_OPTS
+= --with-ssl
=$(STAGING_DIR
)/usr
45 MUTT_CONF_OPTS
+= --without-ssl
48 MUTT_CONF_OPTS
+= --without-ssl
51 # Avoid running tests to check for:
52 # - target system is *BSD
53 # - C99 conformance (snprintf, vsnprintf)
54 # - behaviour of the regex library
55 # - if mail spool directory is world/group writable
56 # - we have a working libiconv
59 mutt_cv_c99_snprintf
=yes \
60 mutt_cv_c99_vsnprintf
=yes \
61 mutt_cv_regex_broken
=no \
62 mutt_cv_worldwrite
=yes \
63 mutt_cv_groupwrite
=yes \
64 mutt_cv_iconv_good
=yes \
65 mutt_cv_iconv_nontrans
=no
67 MUTT_CONF_OPTS
+= --with-mailpath
=/var
/mail
70 ln
-sf
/tmp
$(TARGET_DIR
)/var
/mail
72 MUTT_POST_INSTALL_TARGET_HOOKS
+= MUTT_VAR_MAIL
74 $(eval
$(autotools-package
))