board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / s6-rc / s6-rc.mk
blob1c28dcb88ad3ac8083a189d51343f25f215a3e22
1 ################################################################################
3 # s6-rc
5 ################################################################################
7 S6_RC_VERSION = 0.1.0.0
8 S6_RC_SITE = http://skarnet.org/software/s6-rc
9 S6_RC_LICENSE = ISC
10 S6_RC_LICENSE_FILES = COPYING
11 S6_RC_INSTALL_STAGING = YES
12 S6_RC_DEPENDENCIES = s6
14 S6_RC_CONF_OPTS = \
15 --prefix=/usr \
16 --with-sysdeps=$(STAGING_DIR)/usr/lib/skalibs/sysdeps \
17 --with-include=$(STAGING_DIR)/usr/include \
18 --with-dynlib=$(STAGING_DIR)/usr/lib \
19 --with-lib=$(STAGING_DIR)/usr/lib/execline \
20 --with-lib=$(STAGING_DIR)/usr/lib/s6 \
21 --with-lib=$(STAGING_DIR)/usr/lib/skalibs \
22 $(if $(BR2_STATIC_LIBS),,--disable-allstatic) \
23 $(SHARED_STATIC_LIBS_OPTS)
25 define S6_RC_CONFIGURE_CMDS
26 (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure $(S6_RC_CONF_OPTS))
27 endef
29 define S6_RC_BUILD_CMDS
30 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
31 endef
33 define S6_RC_REMOVE_STATIC_LIB_DIR
34 rm -rf $(TARGET_DIR)/usr/lib/s6-rc
35 endef
37 S6_RC_POST_INSTALL_TARGET_HOOKS += S6_RC_REMOVE_STATIC_LIB_DIR
39 define S6_RC_INSTALL_TARGET_CMDS
40 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
41 endef
43 define S6_RC_INSTALL_STAGING_CMDS
44 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
45 endef
47 HOST_S6_RC_DEPENDENCIES = host-s6
49 HOST_S6_RC_CONF_OPTS = \
50 --prefix=$(HOST_DIR)/usr \
51 --libexecdir=/usr/libexec \
52 --with-sysdeps=$(HOST_DIR)/usr/lib/skalibs/sysdeps \
53 --with-include=$(HOST_DIR)/usr/include \
54 --with-dynlib=$(HOST_DIR)/usr/lib \
55 --disable-static \
56 --enable-shared \
57 --disable-allstatic
59 define HOST_S6_RC_CONFIGURE_CMDS
60 (cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure $(HOST_S6_RC_CONF_OPTS))
61 endef
63 define HOST_S6_RC_BUILD_CMDS
64 $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
65 endef
67 define HOST_S6_RC_INSTALL_CMDS
68 $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install-dynlib install-bin
69 rm -f $(HOST_DIR)/usr/bin/s6-rc-dryrun
70 endef
72 $(eval $(generic-package))
73 $(eval $(host-generic-package))