board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / sdl_mixer / sdl_mixer.mk
blob897b308e9dc41cbcf5f30b11059561e4f6e92619
1 ################################################################################
3 # sdl_mixer
5 ################################################################################
7 SDL_MIXER_VERSION = 1.2.12
8 SDL_MIXER_SOURCE = SDL_mixer-$(SDL_MIXER_VERSION).tar.gz
9 SDL_MIXER_SITE = http://www.libsdl.org/projects/SDL_mixer/release
10 SDL_MIXER_LICENSE = zlib
11 SDL_MIXER_LICENSE_FILES = COPYING
13 SDL_MIXER_INSTALL_STAGING = YES
14 SDL_MIXER_DEPENDENCIES = sdl
16 # We're patching configure.in, so we need to autoreconf
17 SDL_MIXER_AUTORECONF = YES
18 SDL_MIXER_AUTORECONF_OPTS = -Iacinclude
20 SDL_MIXER_CONF_OPTS = \
21 --without-x \
22 --with-sdl-prefix=$(STAGING_DIR)/usr \
23 --disable-music-midi \
24 --disable-music-mod \
25 --disable-music-mp3 \
26 --disable-music-flac # configure script fails when cross compiling
28 ifeq ($(BR2_PACKAGE_LIBMAD),y)
29 SDL_MIXER_CONF_OPTS += --enable-music-mp3-mad-gpl
30 SDL_MIXER_DEPENDENCIES += libmad
31 else
32 SDL_MIXER_CONF_OPTS += --disable-music-mp3-mad-gpl
33 endif
35 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
36 SDL_MIXER_CONF_OPTS += --enable-music-ogg
37 SDL_MIXER_DEPENDENCIES += libvorbis
38 else
39 SDL_MIXER_CONF_OPTS += --disable-music-ogg
40 endif
42 $(eval $(autotools-package))