1 ################################################################################
5 ################################################################################
8 SLANG_SITE
= http
://www.jedsoft.org
/releases
/slang
10 SLANG_LICENSE_FILES
= COPYING
11 SLANG_INSTALL_STAGING
= YES
12 SLANG_CONF_OPTS
= --with-onig
=no
15 # Racy and we don't have/do libtermcap
16 define SLANG_DISABLE_TERMCAP
17 $(SED
) '/^TERMCAP=/s:=.*:=:' $(@D
)/configure
19 SLANG_POST_PATCH_HOOKS
+= SLANG_DISABLE_TERMCAP
21 # Absolute path hell, sigh...
22 ifeq ($(BR2_PACKAGE_LIBPNG
),y
)
23 SLANG_CONF_OPTS
+= --with-png
=$(STAGING_DIR
)/usr
24 SLANG_DEPENDENCIES
+= libpng
26 SLANG_CONF_OPTS
+= --with-png
=no
28 ifeq ($(BR2_PACKAGE_PCRE
),y
)
29 SLANG_CONF_OPTS
+= --with-pcre
=$(STAGING_DIR
)/usr
30 SLANG_DEPENDENCIES
+= pcre
32 SLANG_CONF_OPTS
+= --with-pcre
=no
34 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
35 SLANG_CONF_OPTS
+= --with-z
=$(STAGING_DIR
)/usr
36 SLANG_DEPENDENCIES
+= zlib
38 SLANG_CONF_OPTS
+= --with-z
=no
41 ifeq ($(BR2_PACKAGE_NCURSES
),y
)
42 SLANG_DEPENDENCIES
+= ncurses
43 SLANG_CONF_ENV
+= ac_cv_path_nc5config
=$(STAGING_DIR
)/usr
/bin
/ncurses5-config
45 SLANG_CONF_OPTS
+= ac_cv_path_nc5config
=no
48 ifeq ($(BR2_PACKAGE_READLINE
),y
)
49 SLANG_CONF_OPTS
+= --with-readline
=gnu
50 SLANG_DEPENDENCIES
+= readline
51 ifeq ($(BR2_STATIC_LIBS
),y
)
52 SLANG_CONF_ENV
+= LIBS
="`$(STAGING_DIR)/usr/bin/ncurses5-config --libs`"
56 ifeq ($(BR2_STATIC_LIBS
),y
)
57 SLANG_MAKE_OPTS
= static
58 SLANG_INSTALL_STAGING_OPTS
= DESTDIR
=$(STAGING_DIR
) install-static
59 SLANG_INSTALL_TARGET_OPTS
= DESTDIR
=$(TARGET_DIR
) install-static
62 $(eval
$(autotools-package
))