1 ################################################################################
5 ################################################################################
8 SPICE_SOURCE
= spice-
$(SPICE_VERSION
).
tar.bz2
9 SPICE_SITE
= http
://www.spice-space.org
/download
/releases
10 SPICE_LICENSE
= LGPLv2.1
+
11 SPICE_LICENSE_FILES
= COPYING
12 SPICE_INSTALL_STAGING
= YES
13 SPICE_DEPENDENCIES
= \
23 # We disable everything for now, because the dependency tree can become
24 # quite deep if we try to enable some features, and I have not tested that.
28 --disable-automated-tests \
31 SPICE_DEPENDENCIES
+= host-pkgconf
33 ifeq ($(BR2_PACKAGE_SPICE_CLIENT
),y
)
34 SPICE_CONF_OPTS
+= --enable-client
35 SPICE_DEPENDENCIES
+= xlib_libXfixes xlib_libXrandr
37 SPICE_CONF_OPTS
+= --disable-client
40 ifeq ($(BR2_PACKAGE_SPICE_GUI
),y
)
41 SPICE_CONF_OPTS
+= --enable-gui
42 SPICE_DEPENDENCIES
+= cegui06
44 SPICE_CONF_OPTS
+= --disable-gui
47 ifeq ($(BR2_PACKAGE_SPICE_TUNNEL
),y
)
48 SPICE_CONF_OPTS
+= --enable-tunnel
49 SPICE_DEPENDENCIES
+= slirp
51 SPICE_CONF_OPTS
+= --disable-tunnel
54 SPICE_CONF_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
55 SPICE_MAKE_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
57 # We need to tweak spice.pc because it /forgets/ (for static linking) that
58 # it should link against libz and libjpeg. libz is pkg-config-aware, while
59 # libjpeg isn't, hence the two-line tweak
60 define SPICE_POST_INSTALL_STAGING_FIX_PC
61 $(SED
) 's/^\(Requires.private:.*\)$$/\1 zlib/; s/^\(Libs.private:.*\)$$/\1 -ljpeg/;' \
62 "$(STAGING_DIR)/usr/lib/pkgconfig/spice-server.pc"
64 SPICE_POST_INSTALL_STAGING_HOOKS
+= SPICE_POST_INSTALL_STAGING_FIX_PC
66 # It is currently not possible to detect if stack-protection is available
67 # or not, because it requires support from both the compiler *and* the
68 # C library, but the C library (eg. uClibc) can be compiled without that
69 # support, even if gcc accepts the -fstack-protector-all option.
70 # spice's ./configure only checks for gcc's -fstack-protector-all option,
71 # so it misses the case where the C library doe not provide the requires
73 # A correct fix would be to fix spice's ./configure to also check the C
74 # library, but it might be much more involved.
75 # So, we simply disable it for now. After all, as uClibc's help puts it:
76 # Note that NOEXECSTACK on a kernel with address space randomization
77 # is generally sufficient to prevent most buffer overflow exploits
78 # without increasing code size.
79 SPICE_CONF_OPTS
+= gl_cv_warn__fstack_protector_all
=no
81 $(eval
$(autotools-package
))