board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / trousers / trousers.mk
blob41129eb0534d6fb53634b5b122a3b4663ba2c5a9
1 #############################################################
3 # trousers
5 ##############################################################
7 TROUSERS_VERSION = 0.3.13
8 TROUSERS_SITE = http://downloads.sourceforge.net/project/trousers/trousers/$(TROUSERS_VERSION)
9 TROUSERS_LICENSE = BSD-3c
10 TROUSERS_LICENSE_FILES = LICENSE
11 TROUSERS_INSTALL_STAGING = YES
12 # Need autoreconf because of a patch touching configure.in and Makefile.am
13 TROUSERS_AUTORECONF = YES
14 TROUSERS_DEPENDENCIES = host-pkgconf openssl
16 ifeq ($(BR2_PACKAGE_LIBICONV),y)
17 TROUSERS_DEPENDENCIES += libiconv
18 endif
20 ifeq ($(BR2_arc770d)$(BR2_arc750d),y)
21 TROUSERS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mno-compact-casesi"
22 endif
24 # The TrouSerS build system attempts to create the tss user and group
25 # on the host system. Disable the user checking feature as a
26 # workaround.
27 TROUSERS_CONF_OPTS += --disable-usercheck
29 ifeq ($(BR2_TOOLCHAIN_SUPPORTS_PIE),)
30 TROUSERS_CONF_ENV += \
31 ax_cv_check_cflags___fPIE__DPIE=no \
32 ax_cv_check_ldflags___pie=no
33 endif
35 $(eval $(autotools-package))