1 ################################################################################
5 ################################################################################
8 UNSCD_SOURCE
= nscd-
$(UNSCD_VERSION
).c
9 UNSCD_SITE
= http
://busybox.net
/~vda
/unscd
11 UNSCD_LICENSE_FILES
= $(UNSCD_SOURCE
)
13 define UNSCD_EXTRACT_CMDS
14 cp
$(DL_DIR
)/$($(PKG
)_SOURCE
) $(@D
)/
17 define UNSCD_BUILD_CMDS
19 $(TARGET_CC
) $(TARGET_CFLAGS
) $(TARGET_LDFLAGS
) -o nscd
$(UNSCD_SOURCE
)
22 define UNSCD_INSTALL_TARGET_CMDS
23 $(INSTALL
) -m
755 -D
$(@D
)/nscd
$(TARGET_DIR
)/usr
/sbin
/nscd
24 $(INSTALL
) -m
600 -D package
/unscd
/nscd.conf
$(TARGET_DIR
)/etc
/nscd.conf
27 define UNSCD_INSTALL_INIT_SYSV
28 $(INSTALL
) -m
755 -D package
/unscd
/S46unscd \
29 $(TARGET_DIR
)/etc
/init.d
/S46unscd
33 unscd
-1 unscd
-1 * - - - unscd user
36 $(eval
$(generic-package
))