1 ################################################################################
5 ################################################################################
7 WEBKITGTK_VERSION
= 2.12.5
8 WEBKITGTK_SITE
= http
://www.webkitgtk.org
/releases
9 WEBKITGTK_SOURCE
= webkitgtk-
$(WEBKITGTK_VERSION
).
tar.xz
10 WEBKITGTK_INSTALL_STAGING
= YES
11 WEBKITGTK_LICENSE
= LGPLv2.1
+, BSD-2c
12 WEBKITGTK_LICENSE_FILES
= \
13 Source
/WebCore
/LICENSE-APPLE \
14 Source
/WebCore
/LICENSE-LGPL-2.1
15 WEBKITGTK_DEPENDENCIES
= host-ruby host-flex host-bison host-gperf \
16 enchant harfbuzz icu jpeg libgtk3 libsecret libsoup \
17 libxml2 libxslt sqlite webp
18 WEBKITGTK_CONF_OPTS
= \
19 -DENABLE_API_TESTS
=OFF \
20 -DENABLE_GEOLOCATION
=OFF \
22 -DENABLE_INTROSPECTION
=OFF \
23 -DENABLE_MINIBROWSER
=ON \
24 -DENABLE_SPELLCHECK
=ON \
29 # ARM needs NEON for JIT
30 # i386 & x86_64 don't seem to have any special requirements
31 ifeq ($(BR2_ARM_CPU_HAS_NEON
)$(BR2_i386
)$(BR2_x86_64
),y
)
32 WEBKITGTK_CONF_OPTS
+= -DENABLE_JIT
=ON
34 WEBKITGTK_CONF_OPTS
+= -DENABLE_JIT
=OFF
37 ifeq ($(BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
),y
)
38 WEBKITGTK_CONF_OPTS
+= \
41 WEBKITGTK_DEPENDENCIES
+= gstreamer1 gst1-libav gst1-plugins-base gst1-plugins-good
43 WEBKITGTK_CONF_OPTS
+= \
45 -DENABLE_WEB_AUDIO
=OFF
48 # Only one target platform can be built, assume X11 > Wayland
50 # GTK3-X11 target gives OpenGL from newer libgtk3 versions
51 # Consider this better than EGL + maybe GLESv2 since both can't be built
52 # 2D CANVAS acceleration requires OpenGL proper with cairo-gl
53 ifeq ($(BR2_PACKAGE_LIBGTK3_X11
),y
)
54 WEBKITGTK_CONF_OPTS
+= \
55 -DENABLE_ACCELERATED_2D_CANVAS
=ON \
58 -DENABLE_X11_TARGET
=ON
59 WEBKITGTK_DEPENDENCIES
+= libgl \
60 xlib_libXcomposite xlib_libXdamage xlib_libXrender xlib_libXt
61 # It can use libgtk2 for npapi plugins
62 ifeq ($(BR2_PACKAGE_LIBGTK2
),y
)
63 WEBKITGTK_CONF_OPTS
+= -DENABLE_PLUGIN_PROCESS_GTK2
=ON
64 WEBKITGTK_DEPENDENCIES
+= libgtk2
66 WEBKITGTK_CONF_OPTS
+= -DENABLE_PLUGIN_PROCESS_GTK2
=OFF
69 # GTK3-BROADWAY/WAYLAND needs at least EGL
70 WEBKITGTK_DEPENDENCIES
+= libegl
71 # GLESv2 support is optional though
72 ifeq ($(BR2_PACKAGE_HAS_LIBGLES
),y
)
73 WEBKITGTK_CONF_OPTS
+= \
76 WEBKITGTK_DEPENDENCIES
+= libgles
78 # Disable general OpenGL (shading) if there's no GLESv2
79 WEBKITGTK_CONF_OPTS
+= \
83 # We must explicitly state the wayland target
84 ifeq ($(BR2_PACKAGE_LIBGTK3_WAYLAND
),y
)
85 WEBKITGTK_CONF_OPTS
+= -DENABLE_WAYLAND_TARGET
=ON
89 $(eval
$(cmake-package
))