board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / wget / wget.mk
blob22e057dbae40d5d23a5c124f5265b873e9260c86
1 ################################################################################
3 # wget
5 ################################################################################
7 WGET_VERSION = 1.19.1
8 WGET_SOURCE = wget-$(WGET_VERSION).tar.xz
9 WGET_SITE = $(BR2_GNU_MIRROR)/wget
10 WGET_DEPENDENCIES = host-pkgconf
11 WGET_LICENSE = GPLv3+
12 WGET_LICENSE_FILES = COPYING
14 # Prefer full-blown wget over busybox
15 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
16 WGET_DEPENDENCIES += busybox
17 endif
19 ifeq ($(BR2_PACKAGE_GNUTLS),y)
20 WGET_CONF_OPTS += --with-ssl=gnutls
21 WGET_DEPENDENCIES += gnutls
22 else ifeq ($(BR2_PACKAGE_OPENSSL),y)
23 WGET_CONF_OPTS += --with-ssl=openssl
24 WGET_DEPENDENCIES += openssl
25 else
26 WGET_CONF_OPTS += --without-ssl
27 endif
29 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
30 WGET_DEPENDENCIES += util-linux
31 endif
33 $(eval $(autotools-package))