1 ################################################################################
5 ################################################################################
7 LIBARCHIVE_VERSION
= 3.2.1
8 LIBARCHIVE_SITE
= http
://www.libarchive.org
/downloads
9 LIBARCHIVE_INSTALL_STAGING
= YES
10 LIBARCHIVE_LICENSE
= BSD-2c
, BSD-3c
11 LIBARCHIVE_LICENSE_FILES
= COPYING
13 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR
),y
)
14 ifeq ($(BR2_STATIC_LIBS
),y
)
15 LIBARCHIVE_CONF_OPTS
+= --enable-bsdtar
=static
17 LIBARCHIVE_CONF_OPTS
+= --enable-bsdtar
=shared
20 LIBARCHIVE_CONF_OPTS
+= --disable-bsdtar
23 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCPIO
),y
)
24 ifeq ($(BR2_STATIC_LIBS
),y
)
25 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcpio
=static
27 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcpio
=shared
30 LIBARCHIVE_CONF_OPTS
+= --disable-bsdcpio
33 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCAT
),y
)
34 ifeq ($(BR2_STATIC_LIBS
),y
)
35 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcat
=static
37 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcat
=shared
40 LIBARCHIVE_CONF_OPTS
+= --disable-bsdcat
43 ifeq ($(BR2_PACKAGE_ACL
),y
)
44 LIBARCHIVE_DEPENDENCIES
+= acl
46 LIBARCHIVE_CONF_OPTS
+= --disable-acl
49 ifeq ($(BR2_PACKAGE_ATTR
),y
)
50 LIBARCHIVE_DEPENDENCIES
+= attr
52 LIBARCHIVE_CONF_OPTS
+= --disable-xattr
55 ifeq ($(BR2_PACKAGE_BZIP2
),y
)
56 LIBARCHIVE_CONF_OPTS
+= --with-bz2lib
57 LIBARCHIVE_DEPENDENCIES
+= bzip2
59 LIBARCHIVE_CONF_OPTS
+= --without-bz2lib
62 ifeq ($(BR2_PACKAGE_EXPAT
),y
)
63 LIBARCHIVE_DEPENDENCIES
+= expat
65 LIBARCHIVE_CONF_OPTS
+= --without-expat
68 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
69 LIBARCHIVE_DEPENDENCIES
+= libiconv
71 LIBARCHIVE_CONF_OPTS
+= --without-libiconv-prefix
74 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
75 LIBARCHIVE_DEPENDENCIES
+= libxml2
76 LIBARCHIVE_CONF_ENV
+= XML2_CONFIG
=$(STAGING_DIR
)/usr
/bin
/xml2-config
78 LIBARCHIVE_CONF_OPTS
+= --without-xml2
81 ifeq ($(BR2_PACKAGE_LZO
),y
)
82 LIBARCHIVE_DEPENDENCIES
+= lzo
84 LIBARCHIVE_CONF_OPTS
+= --without-lzo2
87 ifeq ($(BR2_PACKAGE_NETTLE
),y
)
88 LIBARCHIVE_DEPENDENCIES
+= nettle
90 LIBARCHIVE_CONF_OPTS
+= --without-nettle
93 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
94 LIBARCHIVE_DEPENDENCIES
+= openssl
96 LIBARCHIVE_CONF_OPTS
+= --without-openssl
99 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
100 LIBARCHIVE_DEPENDENCIES
+= zlib
102 LIBARCHIVE_CONF_OPTS
+= --without-zlib
105 # libarchive requires LZMA with thread support in the toolchain
106 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
)$(BR2_PACKAGE_XZ
),yy
)
107 LIBARCHIVE_DEPENDENCIES
+= xz
108 LIBARCHIVE_CONF_OPTS
+= --with-lzma
110 LIBARCHIVE_CONF_OPTS
+= --without-lzma
113 # The only user of host-libarchive needs zlib support
114 HOST_LIBARCHIVE_DEPENDENCIES
= host-zlib
115 HOST_LIBARCHIVE_CONF_OPTS
= \
123 --without-libiconv-prefix \
130 $(eval
$(autotools-package
))
131 $(eval
$(host-autotools-package
))