1 ################################################################################
5 ################################################################################
7 AICCU_VERSION
= 20070115
8 AICCU_SOURCE
= aiccu_
$(AICCU_VERSION
).
tar.gz
9 AICCU_SITE
= http
://www.sixxs.net
/archive
/sixxs
/aiccu
/unix
10 AICCU_LICENSE
= SixXS License
, concise redistribution license
11 AICCU_LICENSE_FILES
= doc
/LICENSE
12 AICCU_DEPENDENCIES
= gnutls
14 AICCU_LFDLAGS
= $(TARGET_LDFLAGS
)
16 # aiccu forgets to link with gnutls' dependencies breaking the build when
18 ifeq ($(BR2_STATIC_LIBS
),y
)
19 AICCU_LDFLAGS
+= `$(PKG_CONFIG_HOST_BINARY) --libs gnutls`
22 # dummy RPM_OPT_FLAGS to disable stripping
23 define AICCU_BUILD_CMDS
24 $(TARGET_CONFIGURE_OPTS
) LDFLAGS
="$(AICCU_LDFLAGS)" $(MAKE
) \
25 CC
="$(TARGET_CC)" RPM_OPT_FLAGS
=1 -C
$(@D
)/unix-console
all
28 define AICCU_INSTALL_TARGET_CMDS
29 $(INSTALL
) -D
-m
0755 $(@D
)/unix-console
/aiccu \
30 $(TARGET_DIR
)/usr
/sbin
/aiccu
31 $(INSTALL
) -D
-m
0644 $(@D
)/doc
/aiccu.conf \
32 $(TARGET_DIR
)/etc
/aiccu.conf
35 define AICCU_INSTALL_INIT_SYSV
36 $(INSTALL
) -D
-m
0755 $(@D
)/doc
/aiccu.init \
37 $(TARGET_DIR
)/etc
/init.d
/S50aiccu
40 $(eval
$(generic-package
))