1 ################################################################################
5 ################################################################################
7 APACHE_VERSION
= 2.4.25
8 APACHE_SOURCE
= httpd-
$(APACHE_VERSION
).
tar.bz2
9 APACHE_SITE
= http
://archive.apache.org
/dist/httpd
10 APACHE_LICENSE
= Apache-2.0
11 APACHE_LICENSE_FILES
= LICENSE
13 APACHE_INSTALL_STAGING
= YES
14 # We have a patch touching configure.in and Makefile.in,
15 # so we need to autoreconf:
16 APACHE_AUTORECONF
= YES
17 APACHE_DEPENDENCIES
= apr apr-util pcre
20 ap_cv_void_ptr_lt_long
=no \
21 PCRE_CONFIG
=$(STAGING_DIR
)/usr
/bin
/pcre-config
23 ifeq ($(BR2_PACKAGE_APACHE_MPM_EVENT
),y
)
25 else ifeq ($(BR2_PACKAGE_APACHE_MPM_PREFORK
),y
)
27 else ifeq ($(BR2_PACKAGE_APACHE_MPM_WORKER
),y
)
32 --sysconfdir
=/etc
/apache2 \
33 --with-apr
=$(STAGING_DIR
)/usr \
34 --with-apr-util
=$(STAGING_DIR
)/usr \
35 --with-pcre
=$(STAGING_DIR
)/usr
/bin
/pcre-config \
40 --without-suexec-bin \
41 --enable-mods-shared
=all \
42 --with-mpm
=$(APACHE_MPM
) \
46 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
47 APACHE_DEPENDENCIES
+= libxml2
48 # Apache wants the path to the header file, where it can find
53 --with-libxml2
=$(STAGING_DIR
)/usr
/include/libxml2
60 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
61 APACHE_DEPENDENCIES
+= openssl
64 --with-ssl
=$(STAGING_DIR
)/usr
66 APACHE_CONF_OPTS
+= --disable-ssl
69 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
70 APACHE_DEPENDENCIES
+= zlib
73 --with-z
=$(STAGING_DIR
)/usr
75 APACHE_CONF_OPTS
+= --disable-deflate
78 define APACHE_FIX_STAGING_APACHE_CONFIG
79 $(SED
) 's%/usr/build%$(STAGING_DIR)/usr/build%' $(STAGING_DIR
)/usr
/bin
/apxs
80 $(SED
) 's%^prefix =.*%prefix = $(STAGING_DIR)/usr%' $(STAGING_DIR
)/usr
/build
/config_vars.mk
82 APACHE_POST_INSTALL_STAGING_HOOKS
+= APACHE_FIX_STAGING_APACHE_CONFIG
84 define APACHE_CLEANUP_TARGET
85 $(RM
) -rf
$(TARGET_DIR
)/usr
/manual
$(TARGET_DIR
)/usr
/build
87 APACHE_POST_INSTALL_TARGET_HOOKS
+= APACHE_CLEANUP_TARGET
89 $(eval
$(autotools-package
))