cjson: bump to version 1.4.3
[buildroot-gz.git] / package / espeak / espeak.mk
blob734ec30e544c2cd6c61a1d88f39c8c844a0fde1e
1 ################################################################################
3 # espeak
5 ################################################################################
7 ESPEAK_VERSION_MAJOR = 1.48
8 ESPEAK_VERSION = $(ESPEAK_VERSION_MAJOR).04
9 ESPEAK_SOURCE = espeak-$(ESPEAK_VERSION)-source.zip
10 ESPEAK_SITE = http://downloads.sourceforge.net/project/espeak/espeak/espeak-$(ESPEAK_VERSION_MAJOR)
11 ESPEAK_LICENSE = GPLv3+
12 ESPEAK_LICENSE_FILES = License.txt
14 ifeq ($(BR2_PACKAGE_ESPEAK_AUDIO_BACKEND_ALSA),y)
15 ESPEAK_AUDIO_BACKEND = portaudio
16 ESPEAK_DEPENDENCIES = portaudio
17 endif
18 ifeq ($(BR2_PACKAGE_ESPEAK_AUDIO_BACKEND_PULSEAUDIO),y)
19 ESPEAK_AUDIO_BACKEND = pulseaudio
20 ESPEAK_DEPENDENCIES = pulseaudio
21 endif
23 define ESPEAK_EXTRACT_CMDS
24 $(UNZIP) -d $(@D) $(DL_DIR)/$(ESPEAK_SOURCE)
25 mv $(@D)/espeak-$(ESPEAK_VERSION)-source/* $(@D)
26 $(RM) -r $(@D)/espeak-$(ESPEAK_VERSION)-source
27 endef
29 define ESPEAK_CONFIGURE_CMDS
30 # Buildroot provides portaudio V19, see ReadMe file for more details.
31 cp $(@D)/src/portaudio19.h $(@D)/src/portaudio.h
32 endef
34 define ESPEAK_BUILD_CMDS
35 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS) \
36 AUDIO="$(ESPEAK_AUDIO_BACKEND)" all
37 endef
39 define ESPEAK_INSTALL_TARGET_CMDS
40 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src DESTDIR="$(TARGET_DIR)" install
41 endef
43 $(eval $(generic-package))