cjson: bump to version 1.4.3
[buildroot-gz.git] / package / nss-pam-ldapd / nss-pam-ldapd.mk
blobba250829bb8f9e40967e6859e868a0de15bf5382
1 ################################################################################
3 # nss-pam-ldapd
5 ################################################################################
7 NSS_PAM_LDAPD_VERSION = 0.9.6
8 NSS_PAM_LDAPD_SITE = http://arthurdejong.org/nss-pam-ldapd
9 NSS_PAM_LDAPD_LICENSE = LGPLv2.1+
10 NSS_PAM_LDAPD_LICENSE_FILES = COPYING
11 NSS_PAM_LDAPD_INSTALL_STAGING = YES
13 NSS_PAM_LDAPD_CONF_OPTS = --disable-sasl
14 NSS_PAM_LDAPD_DEPENDENCIES = openldap
16 ifeq ($(BR2_PACKAGE_NSS_PAM_LDAPD_UTILITIES),y)
17 NSS_PAM_LDAPD_CONF_OPTS += --enable-utils
18 else
19 NSS_PAM_LDAPD_CONF_OPTS += --disable-utils
20 endif
22 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
23 NSS_PAM_LDAPD_CONF_OPTS += --enable-pam
24 NSS_PAM_LDAPD_DEPENDENCIES += linux-pam
25 else
26 NSS_PAM_LDAPD_CONF_OPTS += --disable-pam
27 endif
29 define NSS_PAM_LDAPD_INSTALL_INIT_SYSTEMD
30 $(INSTALL) -m 755 -D package/nss-pam-ldapd/nslcd.service \
31 $(TARGET_DIR)/usr/lib/systemd/system/nslcd.service
32 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
33 ln -fs ../../../../usr/lib/systemd/system/nslcd.service \
34 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/nslcd.service
35 endef
37 define NSS_PAM_LDAPD_INSTALL_INIT_SYSV
38 $(INSTALL) -m 755 -D package/nss-pam-ldapd/S45nslcd \
39 $(TARGET_DIR)/etc/init.d/S45nslcd
40 endef
42 define NSS_PAM_LDAPD_USERS
43 nslcd -1 nslcd -1 * - - - nslcd user
44 endef
46 $(eval $(autotools-package))