1 ################################################################################
5 ################################################################################
7 SYSDIG_VERSION
= 0.1.100
8 SYSDIG_SITE
= $(call github
,draios
,sysdig
,$(SYSDIG_VERSION
))
10 SYSDIG_LICENSE_FILES
= COPYING
11 SYSDIG_CONF_OPTS
= -DUSE_BUNDLED_LUAJIT
=OFF
-DUSE_BUNDLED_ZLIB
=OFF \
12 -DUSE_BUNDLED_JSONCPP
=OFF
-DENABLE_DKMS
=OFF
13 SYSDIG_DEPENDENCIES
= zlib luajit jsoncpp
14 SYSDIG_SUPPORTS_IN_SOURCE_BUILD
= NO
16 # sysdig creates the module Makefile from a template, which contains a
17 # single place-holder, KBUILD_FLAGS, wich is only replaced with two
19 # - debug flags, which we don't care about here,
20 # - 'sysdig-feature' flags, which are never set, so always empty
21 # So, just replace the place-holder with the only meaningful value: nothing.
22 define SYSDIG_MODULE_GEN_MAKEFILE
23 $(INSTALL
) -m
0644 $(@D
)/driver
/Makefile.in
$(@D
)/driver
/Makefile
24 $(SED
) 's/@KBUILD_FLAGS@//;' $(@D
)/driver
/Makefile
26 SYSDIG_POST_PATCH_HOOKS
+= SYSDIG_MODULE_GEN_MAKEFILE
28 # Don't build the driver as part of the 'standard' procedure, we'll
29 # build it on our own with the kernel-module infra.
30 SYSDIG_CONF_OPTS
+= -DBUILD_DRIVER
=OFF
32 SYSDIG_MODULE_SUBDIRS
= driver
33 SYSDIG_MODULE_MAKE_OPTS
= KERNELDIR
=$(LINUX_DIR
)
35 $(eval
$(kernel-module
))
36 $(eval
$(cmake-package
))