sngrep: fix error if gnutls and openssl are both enabled
[buildroot-gz.git] / package / doxygen / doxygen.mk
blobcf7dfee2a545ce740ed462a4753424898020454a
1 ################################################################################
3 # doxygen
5 ################################################################################
7 DOXYGEN_VERSION = 1.8.9.1
8 DOXYGEN_SOURCE = doxygen-$(DOXYGEN_VERSION).src.tar.gz
9 DOXYGEN_SITE = http://ftp.stack.nl/pub/users/dimitri
10 DOXYGEN_LICENSE = GPLv2
11 DOXYGEN_LICENSE_FILES = LICENSE
12 HOST_DOXYGEN_DEPENDENCIES = host-flex host-bison
14 define HOST_DOXYGEN_CONFIGURE_CMDS
15 (cd $(@D); $(HOST_MAKE_ENV) ./configure --shared --prefix=$(HOST_DIR)/usr)
16 endef
18 define HOST_DOXYGEN_BUILD_CMDS
19 $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
20 endef
22 define HOST_DOXYGEN_INSTALL_CMDS
23 $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
24 endef
26 # Doxygen's configure is a handwritten script, not an autotools-generated one.
27 # It doesn't accept host-autotools-package default arguments, so we have to
28 # call host-generic-package here.
29 $(eval $(host-generic-package))