1 ################################################################################
5 ################################################################################
7 LIBGDIPLUS_VERSION
= 4.2
8 LIBGDIPLUS_SITE
= $(call github
,mono
,libgdiplus
,$(LIBGDIPLUS_VERSION
))
10 # Although there is a LICENSE file thas specifies LGPL or MPLv1.1,
11 # looks like it is incorrect. The actual source files specify that
12 # they're licensed under MIT, and so does the COPYING file (and they
13 # all predate the addition of the LICENSE file).
14 LIBGDIPLUS_LICENSE
= MIT
15 LIBGDIPLUS_LICENSE_FILES
= COPYING src
/carbon-private.h
17 LIBGDIPLUS_INSTALL_STAGING
= YES
19 # github tarball doesn't have configure
20 LIBGDIPLUS_AUTORECONF
= YES
22 LIBGDIPLUS_DEPENDENCIES
= xlib_libXft libglib2 cairo libpng host-pkgconf
24 # API changes in recent versions of libgif makes it incompatible with
25 # this version of libgdiplus, so we are disabling it for now.
26 LIBGDIPLUS_CONF_OPTS
= --without-libgif
28 # there is a bug in the configure script that enables pango support
29 # when passing --without-pango, so let's just not use it
30 ifeq ($(BR2_PACKAGE_PANGO
),y
)
31 LIBGDIPLUS_CONF_OPTS
+= --with-pango
32 LIBGDIPLUS_DEPENDENCIES
+= pango
35 ifeq ($(BR2_PACKAGE_LIBEXIF
),y
)
36 LIBGDIPLUS_CONF_OPTS
+= --with-libexif
37 LIBGDIPLUS_DEPENDENCIES
+= libexif
39 LIBGDIPLUS_CONF_OPTS
+= --without-libexif
42 ifeq ($(BR2_PACKAGE_JPEG
),y
)
43 LIBGDIPLUS_CONF_OPTS
+= --with-libjpeg
=$(STAGING_DIR
)/usr
44 LIBGDIPLUS_DEPENDENCIES
+= jpeg
46 LIBGDIPLUS_CONF_OPTS
+= --without-libjpeg
49 ifeq ($(BR2_PACKAGE_TIFF
),y
)
50 LIBGDIPLUS_CONF_OPTS
+= --with-libtiff
=$(STAGING_DIR
)/usr
51 LIBGDIPLUS_DEPENDENCIES
+= tiff
53 LIBGDIPLUS_CONF_OPTS
+= --without-libtiff
56 $(eval
$(autotools-package
))