sngrep: fix error if gnutls and openssl are both enabled
[buildroot-gz.git] / package / libuio / libuio.mk
blob6d07f1fa863ba950e3dcac45e77917b77b1f3099
1 ################################################################################
3 # libuio
5 ################################################################################
7 # v0.2.7
8 LIBUIO_VERSION = 940861de278cb794bf9d775b76a4d1d4f9108607
9 LIBUIO_SITE = $(call github,Linutronix,libuio,$(LIBUIO_VERSION))
10 LIBUIO_LICENSE = LGPLv2.1 (library), GPLv2 (programs)
11 LIBUIO_LICENSE_FILES = COPYING
12 LIBUIO_CONF_OPTS = --with-glib=no --without-werror
13 LIBUIO_INSTALL_STAGING = YES
15 # Fetched from github, no pre-generated configure script provided
16 LIBUIO_GETTEXTIZE = YES
17 LIBUIO_AUTORECONF = YES
19 # Avoid build issue when makeinfo is missing
20 LIBUIO_CONF_ENV += MAKEINFO=true
22 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
23 LIBUIO_DEPENDENCIES += argp-standalone
24 LIBUIO_LIBS += -largp
25 endif
27 # libuio pulls in libintl if needed, so ensure we also
28 # link against it, otherwise static linking fails
29 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
30 LIBUIO_DEPENDENCIES += gettext
31 LIBUIO_LIBS += -lintl
32 endif
34 LIBUIO_CONF_ENV += LIBS="$(LIBUIO_LIBS)"
36 $(eval $(autotools-package))