sngrep: fix error if gnutls and openssl are both enabled
[buildroot-gz.git] / package / micropython / micropython.mk
blob8336fb436f785f8715bf2eff365160c9628b7080
1 ################################################################################
3 # micropython
5 ################################################################################
7 MICROPYTHON_VERSION = v1.8.7
8 MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
9 MICROPYTHON_LICENSE = MIT
10 MICROPYTHON_LICENSE_FILES = LICENSE
11 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
13 # Use fallback implementation for exception handling on architectures that don't
14 # have explicit support.
15 ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
16 MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
17 endif
19 # When building from a tarball we don't have some of the dependencies that are in
20 # the git repository as submodules
21 MICROPYTHON_MAKE_OPTS = MICROPY_PY_BTREE=0
22 MICROPYTHON_MAKE_OPTS += MICROPY_PY_USSL=0
24 define MICROPYTHON_BUILD_CMDS
25 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/unix \
26 $(MICROPYTHON_MAKE_OPTS) \
27 CROSS_COMPILE=$(TARGET_CROSS) \
28 CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS)
29 endef
31 define MICROPYTHON_INSTALL_TARGET_CMDS
32 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/unix \
33 $(MICROPYTHON_MAKE_OPTS) \
34 CROSS_COMPILE=$(TARGET_CROSS) \
35 CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS) \
36 DESTDIR=$(TARGET_DIR) \
37 PREFIX=$(TARGET_DIR)/usr \
38 install
39 endef
41 $(eval $(generic-package))