sngrep: fix error if gnutls and openssl are both enabled
[buildroot-gz.git] / package / zip / zip.mk
blob66d94b3c68f4090e2fe7cf13857e18ccb77c2616
1 ################################################################################
3 # zip
5 ################################################################################
7 ZIP_VERSION = 30
8 ZIP_SOURCE = zip$(ZIP_VERSION).tgz
9 ZIP_SITE = ftp://ftp.info-zip.org/pub/infozip/src
10 ZIP_LICENSE = Info-ZIP
11 ZIP_LICENSE_FILES = LICENSE
13 ifeq ($(BR2_PACKAGE_BZIP2),y)
14 ZIP_DEPENDENCIES += bzip2
15 endif
17 # Infozip's default CFLAGS.
18 ZIP_CFLAGS = -I. -DUNIX
20 # Disable the support of 16-bit UIDs/GIDs, the test in unix/configure was
21 # removed since it can't work for cross-compilation.
22 ZIP_CFLAGS += -DUIDGID_NOT_16BIT
24 # infozip already defines _LARGEFILE_SOURCE and _LARGEFILE64_SOURCE when
25 # necessary, redefining it on the command line causes some warnings.
26 ZIP_TARGET_CFLAGS = \
27 $(filter-out -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE,$(TARGET_CFLAGS))
29 define ZIP_BUILD_CMDS
30 $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
31 CFLAGS="$(ZIP_TARGET_CFLAGS) $(ZIP_CFLAGS)" \
32 AS="$(TARGET_CC) -c" \
33 -f unix/Makefile generic
34 endef
36 define ZIP_INSTALL_TARGET_CMDS
37 $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) -f unix/Makefile install \
38 prefix=$(TARGET_DIR)/usr
39 endef
41 define HOST_ZIP_BUILD_CMDS
42 $(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) \
43 CFLAGS="$(HOST_CFLAGS) $(ZIP_CFLAGS)" \
44 AS="$(HOSTCC) -c" \
45 -f unix/Makefile generic
46 endef
48 define HOST_ZIP_INSTALL_CMDS
49 $(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) -f unix/Makefile install \
50 prefix=$(HOST_DIR)/usr
51 endef
53 $(eval $(generic-package))
54 $(eval $(host-generic-package))