Microblaze: added architecture support for both big endian and low endian
[buildroot-gz.git] / package / lighttpd / lighttpd.mk
blobb8aa310c96361c566a30b27cfdf6836a6612fb03
1 #############################################################
3 # lighttpd
5 #############################################################
7 LIGHTTPD_VERSION = 1.4.30
8 LIGHTTPD_SITE = http://download.lighttpd.net/lighttpd/releases-1.4.x
9 LIGHTTPD_DEPENDENCIES = host-pkg-config
10 LIGHTTPD_CONF_OPT = \
11 --libdir=/usr/lib/lighttpd \
12 --libexecdir=/usr/lib \
13 --localstatedir=/var \
14 $(if $(BR2_LARGEFILE),,--disable-lfs)
16 ifeq ($(BR2_PACKAGE_LIGHTTPD_OPENSSL),y)
17 LIGHTTPD_DEPENDENCIES += openssl
18 LIGHTTPD_CONF_OPT += --with-openssl
19 else
20 LIGHTTPD_CONF_OPT += --without-openssl
21 endif
23 ifeq ($(BR2_PACKAGE_LIGHTTPD_ZLIB),y)
24 LIGHTTPD_DEPENDENCIES += zlib
25 LIGHTTPD_CONF_OPT += --with-zlib
26 else
27 LIGHTTPD_CONF_OPT += --without-zlib
28 endif
30 ifeq ($(BR2_PACKAGE_LIGHTTPD_BZIP2),y)
31 LIGHTTPD_DEPENDENCIES += bzip2
32 LIGHTTPD_CONF_OPT += --with-bzip2
33 else
34 LIGHTTPD_CONF_OPT += --without-bzip2
35 endif
37 ifeq ($(BR2_PACKAGE_LIGHTTPD_PCRE),y)
38 LIGHTTPD_CONF_ENV = PCRECONFIG=$(STAGING_DIR)/usr/bin/pcre-config
39 LIGHTTPD_DEPENDENCIES += pcre
40 LIGHTTPD_CONF_OPT += --with-pcre
41 else
42 LIGHTTPD_CONF_OPT += --without-pcre
43 endif
45 ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
46 LIGHTTPD_DEPENDENCIES += libxml2 sqlite
47 LIGHTTPD_CONF_OPT += --with-webdav-props --with-webdav-locks
48 else
49 LIGHTTPD_CONF_OPT += --without-webdav-props --without-webdav-locks
50 endif
52 ifeq ($(BR2_PACKAGE_LIGHTTPD_LUA),y)
53 LIGHTTPD_DEPENDENCIES += lua
54 LIGHTTPD_CONF_OPT += --with-lua
55 else
56 LIGHTTPD_CONF_OPT += --without-lua
57 endif
59 define LIGHTTPD_UNINSTALL_TARGET_CMDS
60 rm -f $(TARGET_DIR)/usr/sbin/lighttpd
61 rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel
62 rm -rf $(TARGET_DIR)/usr/lib/lighttpd
63 endef
65 $(eval $(call AUTOTARGETS))