Microblaze: added architecture support for both big endian and low endian
[buildroot-gz.git] / package / openvpn / openvpn.mk
blobbcb121d06034fe54901b2eff3ff94c7cf7f238cd
1 #############################################################
3 # openvpn
5 #############################################################
7 OPENVPN_VERSION = 2.2.2
8 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
9 OPENVPN_CONF_OPT = --enable-small --disable-plugins
11 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
12 OPENVPN_DEPENDENCIES += lzo
13 else
14 OPENVPN_CONF_OPT += --disable-lzo
15 endif
17 ifeq ($(BR2_PACKAGE_OPENVPN_OPENSSL),y)
18 OPENVPN_DEPENDENCIES += openssl
19 else
20 OPENVPN_CONF_OPT += --disable-crypto --disable-ssl
21 endif
23 define OPENVPN_INSTALL_TARGET_CMDS
24 $(INSTALL) -m 755 $(@D)/openvpn \
25 $(TARGET_DIR)/usr/sbin/openvpn
26 if [ ! -f $(TARGET_DIR)/etc/init.d/openvpn ]; then \
27 $(INSTALL) -m 755 -D package/openvpn/openvpn.init \
28 $(TARGET_DIR)/etc/init.d/openvpn; \
30 endef
32 define OPENVPN_UNINSTALL_TARGET_CMDS
33 rm -f $(TARGET_DIR)/usr/sbin/openvpn
34 rm -f $(TARGET_DIR)/etc/init.d/openvpn
35 endef
37 $(eval $(call AUTOTARGETS))